Einführung

Benutzerhandbuch
NCS-Expertentool
Version 1.5

Datum: 27.06.2012

Softing Project Services GmbH

Richard-Reitzner-Allee 6
D-85540 Haar bei München
Telefon (++49) 89/4 56 56-0
Telefax (++49) 89/4 56 56-499

© Copyright BMW AG 1997-2012
All rights reserved


Bearbeitungsstand

Bearbeitungsstand und Änderungshistorie

Version 1.0 vom 04.09.96.
Entspricht Softwarestand "NCS-Expertentool Version 1.0"

Version 1.1 vom 24.03.97.
Entspricht Softwarestand "NCS-Expertentool Version 1.2.2"

Version 1.2 vom 23.12.97.
Entspricht Softwarestand "NCS-Expertentool Version 1.2.4"

Version 1.3 vom 04.03.99.
Entspricht Softwarestand "NCS-Expertentool Version 2.1.2"

Version 1.4 vom 28.08.00.
Entspricht Softwarestand "NCS-Expertentool Version 3.0.0"

Version 1.5 vom 27.06.2012.
Entspricht Softwarestand "NCS-Expertentool Version 4.0.0"


Überblick

Das Dokument beschreibt die Installation, Konfiguration und Bedienung des NCS-Expertentools.

Das NCS-Expertentool stellt eine Oberfläche dar zur Codierung von Steuergeräten mit den Codierdaten im Format des Neuen Codierdatensystems (NCS) und mit Codierablaufbeschreibungsdateien (CABD). Ferner dient es als Oberfläche zum Aufruf der NCS-Kernfunktionen (COAPI).


Installation von Diskette

Installation

Das Einrichten des NCS-Expertentools erfolgt durch den Aufruf des Setupprogramms. Die Routine kopiert das Programm sowie die erforderlichen Dateien und Unterverzeichnisse nach "C:\NCSEXPER".


Verzeichnisstruktur

\NCSEXPER\BIN
Enthält alle erforderlichen Programmdateien (EXE, DLL) und die Initialisierungsdatei NCSEXPER.INI.
Ferner dient es als Arbeitsverzeichnis zur Ablage von Fehlerdateien und sonstigen während des Programmlaufs erzeugten temporären Dateien

\NCSEXPER\CFGDAT
Enthält Initialisierungsdateien für den Codierablaufinterpreter (INPA.INI) und für COAPI (COAPI.INI). Ferner enthält es Textdateien für EDIABAS- und COAPI-Fehlermeldungen und für das NCS-Expertentool.

\NCSEXPER\SGDAT
Enthält Headerdateien und CABDs im Source (IPS) und Objektfileformat (IPO)

\NCSEXPER\STDAT
Default-Verzeichnis für die Steuerdateien für den Verifikationsmodus.

\NCSEXPER\PFL
Enthält die Profildateien (*.PFL).

\NCSEXPER\VERPLATZ
Arbeitsverzeichnis für den Verifikationsmodus zur Ablage der Tracedateien.

\NCSEXPER\WORK
Arbeitsverzeichnis für COAPI und NCS-Expertentool zur Ablage von Trace- und Differenzdateien sowie für Einlesedateien (z.B. für ASW aus Datei lesen). Das Arbeitsverzeichnis kann über die COAPI.INI-Datei geändert werden.


Konfiguration des Programms

Konfiguration des Programmes

Beim NCS-Expertentool kann ein Default-Profil definiert werden. Die meisten der systemabhängigen Einstellungen erfolgen über die Initialisierungsdatei COAPI.INI.


Deafult-Profil bei Programmstart

Default-Profil bei Programmstart definieren

Soll das NCS-Expertentool mit einem definierten Profil gestartet werden, so kann der Profildateiname als Programm-Parameter angegeben werden. Dazu muß im Windows Programm-Manager das NCS-Expertentool-Symbol angeklickt werden und der Menüpunkt "Datei / Eigenschaften" aufgerufen werden.
In dem Dialogfeld "Befehlszeile" ist der Pfad und der Dateiname der Profildatei als Programm-Parameter anzugeben:
z.B. "C:\NCSEXPER\BIN\NCSEXPER.EXE C:\NCSEXPER\PFL\DEFAULT.PFL"


Konfiguration der NCSEXPER-INI

Konfiguration der NCSEXPER.INI

Die Initialisierungsdatei "\NCSEXPER\BIN\NCSEXPER.INI" dient zur Konfiguration von Verzeichnissen und Systemdaten für das Expertentool. Folgende Sektionen und Einträge sind für das NCS-Expertentool von Bedeutung:

Sektion [Pfadangaben]

Hier wird das Verzeichnis "PFAD_TEXTE" angegeben in dem Fehlertextdateien abgelegt werden und das Verzeichnis "PFAD_PROFILE" in dem die Profildateien abgelegt werden.

Sektion [Einstellungen]

Hier können die Koordinaten der Windowposition unter dem Bezeichner "Windowposition" angegeben werden.
Über den Eintrag "VmKonsistenzCheck" kann mit "ON" oder "OFF" die Konsistenzcheckprüfung im VM-Program ein- oder ausgeschalten werden.

Sektion [Remotebetrieb]

1. Eintrag "REMOTE_BETRIEB"
Hier wird der Remotebetrieb ein- oder ausgeschalten.
2. Eintrag "REMOTE_PFAD"
Serververzeichnis über das der Handshakebetrieb zwischen Server
und Client abgewickelt wird.
3. Eintrag "REMOTE_TIMEOUT"
Angabe in "Sekunden". Reagiert das Schaltprogramm während des
Handshakebetriebs nicht auf die Forderungen des Expertentools wird
der Remotebetrieb abgebrochen und das Expertentool geht in
Grundstellung.
4. Eintrag "CBD_ANFORDERUNG"
Damit fordert das Schaltprogram die Datei "CBD_LISTE" an
5. Eintrag "CBD_ERSTELLT"
Das Expertentool signalisiert mit dieser Datei, daß die Datei
"CBD_LISTE" erstellt wurde.
6. Eintrag "CBD_LISTE"
Datei in der das Expertentool die SG-Kurznamen und die CBD-
Dateienamen für die zu schaltenden Steuergeräte tabellarisch
einträgt.
7. Eintrag "CBD_ERROR"
Datei in die das Schaltprogramm die Steuergeräte einträgt, die nicht
geschaltet werden konnten.


Konfiguration der COAPI-INI

Konfiguration der COAPI.INI

Die Initialisierungsdatei "\NCSEXPER\CFGDAT\COAPI.INI" dient zur Konfiguration von Verzeichnissen, Dateinamen und Systemdaten für die COAPI-Kernfunktionen. Folgende Sektionen und Einträge sind für das NCS-Expertentool von Bedeutung:

Sektion [Baureihe]

Über den Eintrag "Baureihe" können die freigegebenen Baureihen angegeben werden (z.B. Baureihe = E38,E39,E46).

Sektion [Pfadangaben]

Der Pfad für komprimierte Codierdaten kann für jede Baureihe angegeben werden (z.B. E46_PFAD_DATEN). Der Eintrag "EXX_PFAD_DATEN" ist für baureihenunabhängige Codierdaten (z.B. SWT-Dateien) gedacht.

Der Pfad für die VM-Gerüste im ASCII-Format und die komprimierten Konfigurationsdateien (z.B. E46_CONF.BAP) kann für jede Baureihe angegeben werden (z.B. E46_PFAD_TAB). Der Eintrag "EXX_PFAD_TAB" ist für baureihenunabhängige VM-Gerüste (z.B. VEXXBEG.000) gedacht.

Der Eintrag "WORKING_DIR" gibt das Verzeichnis an, das für COAPI-Trace- und Differenzdateien verwendet wird (Defaultpfad: \NCSEXPER\WORK).

Sektion [Systemdaten]

Systemdaten, d.h. Funktionsschlüsselwörter mit direkter Parameterzuweisung können über diese Sektion gesetzt werden. Wird für das Systemdatum "CODIERDATUM" kein Wert angegeben, so wird von COAPI automatisch das Tagesdatum ermittelt.

Die Systemdaten GM_SCHLUESSEL, SA_SCHLUESSEL, VN_SCHLUESSEL, AM_SCHLUESSEL, FAHRGESTELL_NR und FAHRGESTELL_NR_KOMPL werden ebenfalls von COAPI automatisch gesetzt.


Menü "Datei"

Über das Dateimenü können Profildateien geöffnet, editiert und gespeichert werden und das Programm beendet werden.

Ab der Profil-Version 1.1 ist im Profil eine Prüfsumme abgespeichert. Diese Prüfsumme wird beim Laden des Profils überprüft. Ist die Prüfsumme nicht korrekt, dann kann das Profil nicht geladen werden.

Profile mit der Version 1.0 sind ab dem 1.1.1998 ungültig und können ab diesem Datum nicht mehr geladen werden.

Ab der NCS-Expertentool Version 4.0.0 sind Profile mit einer Version kleiner 3.0 nicht mehr gültig.

Menüpunkt "Profil laden"

Laden eines neuen Profils. Es werden die Profilbezeichnungen aller Profildateien im Verzeichnis "\NCSEXPER\PFL" ermittelt und in einem Auswahlfenster angezeigt.

Wurde ein Profil im Profileditor geändert, so erscheint zuerst eine Abfrage, ob das aktuelle Profil gespeichert werden soll.

Menüpunkt "Profil editieren"

Editieren des aktuellen Profils im Profileditor. Bevor das Profil editiert werden kann, muß ein Passwort eingegeben werden.

Menüpunkt "Profil speichern"

Speichern des aktuellen Profils. Dieser Menüpunkt ist nur aktiv, wenn das aktuell geladene Profil im Profileditor geändert wurde.

Handelt es sich um ein neues Profil, d.h. daß noch kein Dateiname zugeordnet ist, so wird bei der Auswahl des Menüpunkts das Dialogfeld "Profil speichern unter" angezeigt.

Menüpunkt "Profil speichern unter"

Speichern des aktuellen Profils unter einem neuen Dateinamen. Es erscheint ein Dialogfeld in dem Sie das Laufwerk, das Verzeichnis und den Dateinamen angeben können.

Menüpunkt "Beenden"

Beenden des NCS-Expertentools. Wurde ein Profil im Profileditor geändert, so erscheint eine Abfrage, ob das aktuelle Profil gespeichert werden soll.


Menü "Anzeige"

Über das Anzeigemenü können Fehler- und Tracedateien angezeigt werden.

Menüpunkt "CABI.ERR"

Zeigt die Fehlerdatei an, welche die Fehler, die beim Compilieren der CABD aufgetreten sind, enthält.

Verlassen der Anzeige mit "ESC" oder Alt-F4.

Menüpunkt "ERROR.LOG"

Zeigt die ERROR.LOG Fehlerdatei an, welche die Fehlermeldungen aus den COAPI- und CDH-Funktionen enthält.

Verlassen der Anzeige mit "ESC" oder Alt-F4.

Menüpunkt "CABD-Parameter"

Zeigt die aktuell gesetzten Auftrags- und Ergebnisparameter einer CABD an.

Verlassen der Anzeige mit "ESC" oder Alt-F4.

Menüpunkt "Systemdaten"

Zeigt die aktuellen Systemdaten, d.h. die Funktionsschlüsselwörter mit direkter Parameterzuweisung an.

Verlassen der Anzeige mit "ESC" oder Alt-F4.

Menüpunkt "ASW-Tracedatei"

Zeigt eine im Arbeitsverzeichnis "\NCSEXPER\WORK" vorhandene COAPI-ASW-Tracedatei an

Verlassen der Anzeige mit "ESC" oder Alt-F4.

Menüpunkt "FSW-/PSW-Tracedatei"

Zeigt eine im Arbeitsverzeichnis "\NCSEXPER\WORK" vorhandene COAPI-FSW-/PSW-Tracedatei an

Verlassen der Anzeige mit "ESC" oder Alt-F4.

Menüpunkt "Nettodaten-Tracedatei"

Zeigt eine im Arbeitsverzeichnis "\NCSEXPER\WORK" vorhandene COAPI-Nettodaten-Tracedatei an

Verlassen der Anzeige mit "ESC" oder Alt-F4.

Menüpunkt "Individualisierungs-Tracedatei"

Zeigt eine im Arbeitsverzeichnis "\NCSEXPER\WORK" vorhandene Individualisierungs-Tracedatei an

Verlassen der Anzeige mit "ESC" oder Alt-F4.


Menü "Hilfe"

Über dieses Menü kann die Online-Hilfe gestartet werden und Informationen zum Programm angezeigt werden.

Menüpunkt "Inhalt"

Dieser Befehl zeigt den Eröffnungsbildschirm der Hilfefunktion an.

Menüpunkt "Info..."

Dieser Befehl zeigt Programmversions- und Copyright-Informationen an.


Überblick über einen Codierablauf

Ein typischer Codierablauf sieht folgendermaßen aus:

1. Laden eines Profils über den Menüpunkt "Datei / Profil laden"

2. Funktionstaste "FG/ZCS/FA" anwählen zur Ermittlung der Fahrgestellnummer und des ZCS oder FA.
In dem Funktionstastensubmenü kann der ZCS oder der FA über Handeingabe, Einlesen aus einer Steuerdatei oder Auslesen aus dem Fahrzeug ermittelt werden. Welche Eingabemöglichkeiten aktiv sind, kann im Profileditor festgelegt werden. Die FG/ZCS/FA-Ermittlung wird durch Betätigung der "Zurück"-Fuktionstaste beendet.

3. Nach Setzen der Fahrgestellnummer und des ZCS/FA erfolgt in Abhängigkeit von den Profileinstellungen die Bildung der ASW-, FSW/PSW- und der SGET-Daten.
Ist die Datenbildung erfolgreich, so erscheinen die Funktionstasten "FZG codieren" und "SG bearbeiten".

4. Über die Funktionstaste "FZG codieren" kommt man in das Funktionstastensubmenü zur Fahrzeugcodierung. Über dieses Submenü kann eine Komplettcodierung des Fahrzeugs durchgeführt werden oder COAPI-Kernfunktionen aufgerufen werden, die nicht steuergerätspezifisch sind.
Der Codierablauf bei einer Komplettcodierung ist über den Profileditor konfigurierbar.

5. Über die Funktionstaste "SG bearbeiten" kommt man in das Funktionstastensubmenü zur Steuergerätecodierung.
Über dieses Submenü kann man:
- ein Steuergerät auswählen
- die SGET-Daten für ein Steuergerät ändern
- einen CABD-Job auswähen
- eine Steuergeräteccodierung durchführen
- bzw. einen CABD-Job ausführen
- eine COAPI-Kernfunktionen aufrufen
Der Codierablauf bei einer Steuergerätecodierung ist über den Profileditor konfigurierbar.

6. Nach Verlassen der Funktionstastensubmenüs zur Fahrzeug- bzw. Steuergerätecodierung kann durch erneute Ermittlung des ZCS/FA (siehe Punkt 2) ein neuer Codierablauf gestartet werden.

Eine detaillierte Beschreibung der Bedeutung der einzelnen Funktionstasten im Codierablauf erfolgt bei der Beschreibung des Profileditors, da die Bedeutung abhängig von den Profileinstellungen ist.


Überblick über den Profileditor

Der Profileditor dient zur:

Konfiguration der auswählbaren Funktionen und Funktionstasten

Ein- und Ausschalten der COAPI-Tracefunktionen

Festlegung der Codierdatensatzverarbeitungsschritte

Festlegung des Codierablaufs

Grafische Oberfläche

Der Profileditor stellt die Codierdatensatzverarbeitungsschritte grafisch dar:

Der Profileditor zeigt durch ein grünes Dateisymbol an, welche der Codierdateien (ZST, ZCSUT, CVT, SGET-Tabelle) verarbeitet werden. Voraussetzung für die Verarbeitung einer Codierdatei ist, daß die Verarbeitung aktiviert wurde und daß die erforderlichen Eingangsdaten aktiv sind.

Der Profileditor zeigt durch ein grünes Datenspeichersymbol an, welche der Codierdaten (ASW, FSW/PSW, SGET-Daten) verfügbar sind. Voraussetzung für die Verfügbarkeit von Daten ist, daß ein Verarbeitungsschritt zur Generierung der Daten aktiviert wurde und daß die erforderlichen Eingangsdaten für diesen Verarbeitungsschritt verfügbar sind.

Beenden der Profileditierung und Konsistenzcheck

Das Editieren eines Profils wird durch die Betätigung der OK-Taste im Hauptfenster des Profileditors beendet. Es wird automatisch ein Konsistenzcheck der Profildaten durchgeführt und das Profil in das NCS-Expertentool übernommen.

Der Konsistenzcheck kann auch separat über den entsprechenden Knopf ausgelöst werden.

Durch Betätigung des CANCEL-Knopfs wird das Editieren eines Profils abgebrochen und die Änderungen am Profil verworfen.


Profil-Info einstellen

Über diese Dialogbox können allgemeine Informationen über das Profil angezeigt und eingestellt werden.

Profil-Format-Version

Zeigt die interne Versionsnummer des Profilformates an. Die Versionsnummer wird vom Programm verwaltet und kann nicht geändert werden.

Profil-Dateiname

Zeigt den Pfad und den Dateinamen des Profils an. Der Profil-Dateiname kann im Profileditor nicht geändert werden. Zur Änderung eines Profil-Dateinamens siehe den Menüpunkt "Profil speichern unter".

Profil-Bezeichnung

Kurzbeschreibung des Profils. Dieser Text erscheint bei der Profilauswahl über den Menüpunkt "Profil laden" und in der Programmtitelzeile.

Profil-Kommentar

Einzeiliger Zusatztext für Kommentare oder Hinweise zu dem Profil


Profil-Applikation einstellen

Über diese Dialogbox kann die Applikationskennung eingestellt werden. Diese Applikationskennung wird der CABD als Parameter übergeben. Dadurch kann die CABD applikationsspezfisch unterschiedliche Abläufe durchführen.


Profil-Verifikation einstellen

Über diese Dialogbox können der Verifikationsmodus und der Modus ZCS-Umrechnung im Batchbetrieb eingestellt werden.

Einstellungen Verifikation-Optionen:

Verifikationsmodus EIN

Wenn diese Option angewählt ist, ist die Funktionstaste "Verifikation" aktiv. Die Standardfunktionstasten sind in diesem Modus inaktiv.

Steuergeräte-Codierung EIN

Wenn diese Option angewählt ist, wird während der Abarbeitung der Steuerdatei auch die Codierung der Steuergeräte durchgeführt.

Steuerdatei

Hier kann der Name einer Steuerdatei angegeben werden. Die Datei muß sich im Verzeichnis "\NCSEXPER\STDAT" befinden. Wenn hier ein Name angegeben ist, dann erfolgt nach Anwahl der Funktionstaste "Verifikation" keine Abfrage des Steuerdateinamens.

ZCS-Umrechnung-Batch EIN

Wenn diese Option angewählt ist, ist die Funktionstaste "ZUT-Batch" aktiv. Die Standardfunktionstasten sind in diesem Modus inaktiv.

Steuerdatei

Hier kann der Name einer Steuerdatei angegeben werden. Die Datei muß sich im Verzeichnis "\NCSEXPER\STDAT" befinden. Wenn hier ein Name angegeben ist, dann erfolgt nach Anwahl der Funktionstaste "ZUT-Batch" keine Abfrage des Steuerdateinamens.


Profil-FG/ZCS/FA/Baureihen-Ermittlung einstellen

Über diese Dialogbox können die Funktionstasten für die FG/ZCS/FA/Baureihen-Ermittlung eingestellt werden und Optionen für die manuelle Eingabe der Fahrgestellnummer und des ZCS gesetzt werden.

Hinweis:
Die ZCSUT-Verabeitung wird über "Profil-Codierung einstellen" aktiviert.

FG-/ZCS-/FA-Eingabe-Optionen:

Checksumme berechnen anzeigen

Wenn die Option angewählt wurde, erscheint bei der FGNR-/ZCS-Eingabe-Dialogbox oder FGNR-/FA-Eingabe-Dialogbox das Optionsfeld "Checksumme berechnen" zum Anhängen der Checksumme an die Fahrgestellnummer bzw. an den ZCS. Der FA-Stream wird ohne Checksumme verarbeitet.

Vor Eingabe löschen

Wenn die Option angewählt wurde, werden beim Öffnen der FGNR-/ZCS-Eingabe-Dialogbox oder der FGNR-/FA-Eingabe-Dialogbox die alten Werte für die Fahrgestellnummer bzw. den ZCS/FA vorher gelöscht.

Funktionstasten:

FG/ZCS/ eingeben und FG/FA/ eingeben

Wenn die Option angewählt wurde, sind die Funktionstasten "FG/ZCS eingeben" bzw. "FG/FA eingeben" zur Handeingabe der Fahrgestellnummer und des ZCS/FA aktiv.

FG/ZCS/FA aus Fahrzeug

Wenn die Option angewählt wurde, ist die Funktionstaste "ZCS aus SG" zum Auslesen der Fahrgestellnummer und des ZCS/FA aus dem Fahrzeug aktiv.

Beim Aufruf dieser Funktion im Codierablauf muß der Bediener die Baureihe und das ZCS/FA-Steuergerät auswählen. Anschließend wird das Auslesen der FG und des ZCS/FA gestartet.

Das Anwählen dieser Option aktiviert automatisch auch die Funktionstaste "Baureihe auswählen".

FG/ZCS/FA aus Datei

Wenn die Option angewählt wurde, sind die Funktionstasten zum Einlesen der Fahrgestellnummer und des ZCS/FA aus einer Steuerdatei im Verifikationsplatzformat aktiv.

Im Codierablauf erscheint die Funktionstaste "Datei öffnen", wenn noch keine Steuerdatei geöffnet wurde. Wird diese betätigt, so kann über eine Dateiauswahlbox die Steuerdatei geöffnet werden. Es wird automatisch der erste ZCS aus der Datei gelesen. Nach dem erfolgreichen Öffnen einer Steuerdatei erscheinen daraufhin die Funktionstasten "ZCS aus Datei" zum Einlesen des nächsten ZCS und "Datei schliessen" zum Schliessen der Steuerdatei.

Baureihe auswählen

Wenn die Option angewählt wurde, ist die Funktionstaste "BR auswählen" zum Auswählen der Baureihe aktiv.

Die Funktion dient z.B. zum Wechseln der Baureihe für die Funktion "FG/ZCS/FA aus Fahrzeug".


Profil-ASW-Ermittlung einstellen

Über diese Dialogbox kann die Art der ASW-Datenermittlung eingestellt werden und der ASW-Trace aktiviert werden.

ASW einlesen

Die Auftragsschlüsselwortermittlung kann folgendermaßen eingestellt werden:

ASW-Verarbeitung inaktiv, d.h. es werden keine ASW ermittelt

ASW aus ZST/AT, d.h. die Auftragsschlüsselwörter werden über die ZST/AT-Datei ermittelt. Voraussetzung dafür ist, daß der ZCS/FA verfügbar ist

ASW aus Datei, d.h. die Auftragsschlüsselwörter werden aus einer ASCII-Datei im COAPI-ASW-Tracedateiformat eingelesen

ASW-Trace

Wenn die Option angewählt wurde, wird beim Einlesen der ASW aus der ZST eine COAPI-ASW-Tracedatei im COAPI-Arbeitsverzeichnis ("\NCSEXPER\WORK") angelegt.


Profil-FSW/PSW-Ermittlung einstellen

Über diese Dialogbox kann die Art der FSW/PSW-Datenermittlung eingestellt werden und der FSW/PSW-Trace aktiviert werden.

FSW/PSW einlesen

Die Funktions- und Parameterschlüsselwortermittlung kann folgendermaßen eingestellt werden:

FSWPSW-Verarbeitung inaktiv, d.h. es werden keine FSW/PSW-Daten ermittelt

FSW/PSW aus CVT, d.h. die FSW/PSW-Daten werden über die CVT-Datei ermittelt. Voraussetzung dafür ist, daß die ASW-Daten verfügbar sind

FSW/PSW aus Datei, d.h. die FSW/PSW-Daten werden aus einer ASCII-Datei im COAPI-FSW/PSW-Tracedateiformat eingelesen

FSW/PSW-Trace

Wenn die Option angewählt wurde, wird beim Einlesen der FSW/PSW aus der CVT eine COAPI-FSW/PSW-Tracedatei im COAPI-Arbeitsverzeichnis ("\NCSEXPER\WORK") angelegt.

FSW/PSW-Manipulieren

Wenn die Option angewählt wurde, werden nach der Ermittlung der FSW/PSW-Daten, diese entsprechend dem Inhalt der Manipulationsdatei FSW_PSW.MAN geändert.


Profil-SGET-Ermittlung einstellen

Über diese Dialogbox kann die Art der SGET-Datenermittlung eingestellt werden und die SGET spezifischen Funktionstasten aktiviert werden.

SGET einlesen

Wenn die Option angewählt wurde, werden die SGET-Daten über die SGET-Datei ermittelt. Voraussetzung dafür ist, daß die ASW-Daten verfügbar sind.

Funktionstasten:

Steuergeräteauswahl

Wenn die Option angewählt wurde, ist die Funktionstaste "SG auswählen" zur Auswahl eines Steuergerätes innerhalb der aktuellen Steuergeräteermittlung aktiv.

SGET eingeben

Wenn die Option angewählt wurde, ist die Funktionstaste "SGET ändern" zum Ändern oder Eingeben von SGET-Daten aktiv.


Profil-Codierablauf einstellen

Über diese Dialogbox kann der Codierablauf eingestellt werden und codierspezifische Funktionstasten aktiviert werden.

ZCS-löschen/umrechnen/schreiben:

ZCS vor Codierung löschen

Wenn die Option angewählt wurde, wird vor einer Codierung immer der ZCS in allen ZCS-Steuergeräten gelöscht. Nach einer erfolgreichen Codierung wird der ZCS wieder in alle ZCS-Steuergeräte eingetragen.

ZCSUT-Verarbeitung aktiv

Wenn die Option angewählt wurde, wird vor einer Codierung die Steuergeräteidentifikation für alle codierrelevanten Steuergeräte ermittelt und gegebenenfalls, der ZCS über die ZCSUT-Tabelle geändert.

ZCS nach Codierung schreiben

Es kann eine der folgenden Optionen ausgewählt werden:

ZCS nach Codierung nicht schreiben:
Der ZCS wird nach einer erfolgreichen Codierung nur geschrieben, wenn die Option "ZCS vor Codierung löschen" aktiv ist

ZCS nach Codierung immer schreiben:
Nach einer erfolgreichen Codierung wird der ZCS immer in alle ZCS-Steuergeräte eingetragen

ZCS nur nach Änderung schreiben:
Nach einer erfolgreichen Codierung wird der ZCS nur dann in alle ZCS-Steuergeräte eingetragen, wenn der ZCS durch eine ZCSUT-Umrechnung geändert wurde

Nettodaten-Trace

Wenn die Option angewählt wurde, wird beim Einlesen der Nettodaten aus der CBD eine COAPI-Nettodaten-Tracedatei im COAPI-Arbeitsverzeichnis ("\NCSEXPER\WORK") angelegt.

Spezial-CABD-Job

Hier kann ein anderer CABD-Jobname angegeben werden, als der Default-Job "SG_CODIEREN".

Funktionstasten:

Codierjob ändern

Wenn die Option angewählt wurde, ist die Funktionstaste "Job ändern" zur Auswahl eines CABD-Jobs aktiv. Es werden alle CABD-Jobs aus der aktuellen CABD ermittelt und angezeigt.

Kernfunktionen

Wenn die Option angewählt wurde, ist die Funktionstaste "Kernfunktionen" zur Auswahl einer COAPI-Kernfunktion aktiv.

Im Funktionstastensubmenü "SG bearbeiten" werden zusätzlich steuergerätspezifische Kernfunktionen angezeigt.

SG bearbeiten

Wenn die Option angewählt wurde, ist das Funktionstastensubmenü "SG bearbeiten" zur Steuergeräteeinzelcodierung aktiv.

Über das Eingabefeld "Funktionstastentext" kann eine andere Beschriftung für die Funktionstaste zum Starten einer SG-Codierung angegeben werden.

Fahrzeug codieren

Wenn die Option angewählt wurde, ist das Funktionstastensubmenü "FZG codieren" zur Codierung aller Steuergeräte eines Fahrzeugs aktiv.

Über das Eingabefeld "Funktionstastentext" kann eine andere Beschriftung für die Funktionstaste zum Starten einer Fahrzeugcodierung angegeben werden.


Profil-Individualisierung einstellen

Über diese Dialogbox können die Individualisierung und der Individualisierungs-Trace aktiviert werden.

Individualisierung

Wenn die Option angewählt wurde, wird die Individualisierung aktiviert.

Individualisierungs-Trace

Wenn die Option angewählt wurde, wird beim der Individualisierung eine COAPI-Individualisierungs-Tracedatei im COAPI-Arbeitsverzeichnis ("\NCSEXPER\WORK") angelegt.


Überblick über die Individualisierung

Der Individualisierung dient zur:

Anzeige der individualisierbaren FSWs

Auslesen der aktuellen Einstellung der individualisierbaren FSWs des Fahrzeugs

Ändern der aktuellen PSWs der individualisierbaren FSWs

Codieren der geänderten PSWs eines Fahrzeugs

Grafische Oberfläche

Die Oberfläche der Individualisierung besteht aus einer speziellen Bedienseite mit 4 Anzeige-Listen:

Modus-Liste

· FSW-Liste

PSW-Liste

Liste der geänderten PSWs

Der typische Ablauf bei der Individualisierung sieht folgendermaßen aus:

1. Funktionstaste "Individualisierung" anwählen.
-> Die Bedienseite Individualisierung zeigt die für den ZCS/FA möglichen individualisierbaren FSWs mit den auswählbaren PSWs. Der Sollzustand der PSWs ist mit einem vorangestellten 'S' gekennzeichnet.

2. Funktionstaste "Auslesen" anwählen.
-> Der Istzustand der PSWs der individualisierbaren FSWs wird ermittelt und mit einem vorangestellten 'I' gekennzeichnet.

3. Funktionstaste "Übernehmen" anwählen.
-> Das aktuell angewählte PSW wird als neuer Sollwert für das Fahrzeug in die Liste der gänderten PSWs übernommen.

4. Funktionstaste "Übertragen" anwählen.
-> Die Steuergeräte des Fahrzeugs bei denen PSWs geändert wurden werden codiert. Geändert werden dabei die PSWs der Liste der geänderten PSWs.


Überblick über die Verifikation und ZCSUT

Im Profileditor kann unter dem Auswahlbutton "Verifikation" die Verifikation vom ZCS/FA und die Umschlüsselung vom ZCS (ZCSUT) eingestellt werden.

Verifikation

Hier wird aus einer Steuerdatei ("*.ssd"), in der ein oder mehrere ZCS/FA enthalten sind, die Steuergeräte mit den dazugehörigen Codierindices ermittelt.

Beispiel einer Steuerdatei:

M E38_CODIERSCHL ALL

;

Z 001 WBACH31E36AB12345J 41110100J 00000A40080000084 000000CEA8J

Y LCM 16 GR2 04 IHK 04 IKE 05 EWS 01

M E65_CODIERSCHL ALL

A 002 WBAGX210X0AB12345W E65_ \

*GN21 \

#0100 \

%0609 \

&A6C9 \

$199 \

$423 \

$445 \

|6543

Y CAS 01 SIM 02

Zeilen denen ein Semikolon vorangestellt ist sind Kommentarzeilen. In Zeilen, die mit "M" beginnen steht die Baureihe. Daran anschließend steht "_CODIERSCHL". Am Ende der Zeile kann entweder "ALL" stehen, wobei alle Steuergeräte verifiziert werden, die im ZCS stehen, oder ein SG-Name, wobei nur dieses SG speziell verifiziert wird. In Zeilen, die mit "Z" beginnen steht der ZCS. Dabei wird jeweils mit einem Leerzeichen getrennt die Auftragskennung, die Fahrgestellnummer, der Gm-Schlüssel, der Sa-Schlüssel und der Vn-Schlüssel angegeben.

Zeilen, die mit "Y" beginnen werden für die "SGVT"-Verarbeitung angegeben. Dabei wird jeweils mit einem Leerzeichen getrennt das SG mit seinem Ist-Codierindex angegeben. Eine "Y"-Zeile sollte 80 Zeichen nicht überschreiten. Es können beliebig viele "Y"-Zeilen untereinander angeordnet werden.

Zeilen, die mit "A" beginnen werden für die Fahrzeugauftragsverarbeitung herangezogen. Dabei wird jeweils mit einem Leerzeichen getrennt die Auftragskennung, die Fahrgestellnummer und der FA-Stream angegeben. Dabei kann der gesamte FA-Stream (maximal 2 KB) in der 1. Zeile stehen. Der FA-Stream kann auch in beliebig viele Zeilen getrennt werden (siehe Beispiel). Nach dem zu trennenden Merkmal wird ein Leerzeichen und ein Backslash "\" angegeben. Die Anzahl der Zeichen in einer Folgezeile dürfen 200 Zeichen nicht überschreiten. Wie bei "Z"-Zeilen können nach der "A"-Zeile auch "Y"-Zeilen folgen.

ZCSUT-Batch

Hier können ZCS-Schlüssel in einer Batch-Datei angegeben werden, die aufgrund neuer Steuergeräte mit neuem Codierindex umgeschlüsselt werden müssen.

Beispieldatei:

; E46-Test

Z E46 653212004 00000A00C5BC72AAH 000000000BE KMB CDNR 02 00

Zeilen denen ein Semikolon vorangestellt ist sind Kommentarzeilen. In Zeilen, die mit "Z" beginnen steht die Information zum Umschlüsseln. Dabei werden jeweils mit einem Leerzeichen getrennt die Baureihe, der Gm-Schlüssel, der Sa-Schlüssel, der Vn-Schlüssel, das betreffende Steuergerät, das Kennwort für den Codierindex "CDNR", der neue Codierindex und der vorhandene Codierindex angegeben.


Glossar

ASW

Auftragsschlüsselwort

CABD

Codierablaufbeschreibungsdatei

CBD

Codierbeschreibungsdatei

COAPI

Codierapplikationsinterface.

CVT

Codiervariantentabelle

FA

Fahrzeugauftrag

FSW/PSW

Funkions- und Parameterschlüsselwort

FSW

Funktionsschlüsselwort

IPO

Codierablaufinterpreter-Objektcodedatei

IPS

Codierablaufinterpreter-Sourcedatei

NCS

Neues Codierdatensystem

PSW

Parameterschlüsselwort

SGET

Steuergeräteermittlung

SWT

Schlüsselworttabelle

Verifikationsmodus

Der Verifikationsmodus dient dazu automatisch die Aufträge einer Steuerdatei abzuarbeiten. Die Ergebnisdateien werden abgespeichert. Das Ergebnis wird in der Reportdatei protokolliert.

ZCS

Zentraler Codierschlüssel

ZCSUT

Zentraler Codierschlüssel Umrechnungstabelle

ZST

Zentralschlüsseltabelle