Command Line

Command Line Options

BEST2.EXE [-C|c <CommandFile>] [-Q|q] [-B|b] [-I|i] [-A|a] [-S|s] [-T|t] [-L|l <LibraryFile>] [-Z|z <IncludeDir>] [-R|r RevMajor.RevMinor <UsrName>] [-O|o <ErrorLogFilename>] [-P|p <PasswordLabel>|@<Path\PasswordLabelFile>] <SourceFiles> [<OutputDir>]

BEST2WIN.EXE [-C|c <CommandFile>] [-B|b] [-I|i] [-A|a] [-S|s] [-L|l <LibraryFile>] [-Z|z <IncludeDir>] [-R|r RevMajor.RevMinor <UsrName>] [-O|o <ErrorLogFilename>] [-P|p <PasswordLabel>|@<Path\PasswordLabelFile>] <SourceFiles> [<OutputDir>]

<SourceFiles>

Gibt die zu übersetzende Datei mit Pfad an.

<OutputDir>

Gibt an, in welchem Directory die verschiedenen Ausgabedateien erzeugt werden sollen.

-L <LibraryFile>

Gibt an, welche Bibliotheksdatei verwendet werden soll.

-Z <IncludePath>

Gibt an, in welchem Verzeichnis nach Include-Dateien gesucht werden soll.

-A

Wenn aktiviert, wird eine Assemblerdatei mit der Erweiterung *.b1v oder *.b1g erzeugt.

-S

Wenn aktiviert, wird eine Preprozessordatei mit der Erweiterung *.p2v oder *.p2g erzeugt.

-I

Wenn aktiviert, wird eine Infodatei mit der Erweiterung *.biv oder *.big erzeugt.

-B

Wenn aktiviert, werden die Fehlermeldungen in die Datei <OutputDir>\<Error Log Filename>.out geschrieben. BEST2/BEST2WIN läuft im Batch-Mode !

-R RevMajor.RevMinor <UsrName>

Die in den Revision Info Feldern eingetragenen Daten werden in die Objektdatei geschrieben, nicht die in der Sourcedatei angegebenen.

-O <ErrorLogFilename>

Festlegung des Namens der Error-Log-Datei ohne Pfad und ohne Extension.

Die Error-Log-Datei wird mit der Extension .out im <Outputdir> abgelegt. Als Voreinstellung wird best2err bzw. best2err.out verwendet.

-P <PasswordLabel>

Das zum PasswordLabel gehörende Paßword aus der EDIABAS-Installation wird in die Objektdatei geschrieben. Wird dem PasswordLabel ein '@' vorangestellt, dann wird das PasswordLabel als Datei mit mehreren Paßwortlabels interpretiert. Jedes Label muß in der Datei in einer eigenen Zeile stehen.

-C <CommandFile>

Wenn aktiviert, wird der Inhalt der angegebenen Datei als Kommandozeilenparameter interpretiert.

-T

Wenn aktiviert, wird eine Übersetzung nur bei nicht existierender Objektdatei oder veralteteter Objektdatei durchgeführt.
Hinweis: Diese Option ist nur für BEST2.EXE verfügbar!

-Q

Wenn aktiviert, erfolgt die Beendigung von BEST2 ohne Quittierung durch den Benutzer.
Hinweis: Diese Option ist nur für BEST2.EXE verfügbar!