EDIABAS ToolSet

Willkommen in der EDIABAS ToolSet Hilfe Version 4.0.0.

EDIABAS ToolSet Historie

EDIABAS ToolSet ohne Maus

Übersicht

INI Datei

Kommandozeile

Klicken auf den entsprechenden Punkt im Bild.


About

EDIABAS ToolSet Hilfe

Hr. Drexel

BMW AG

TI-538

Tel.: +49 89 382 44236

email: reinhold.drexel@bmw.de


EDIABAS ToolSet Historie

02.2011

V4.0.0

Support chinesisches Windows XP, Windows 7

11.2010

V3.9.2

Direkte Job-Ausführung im Argument-Assistenten möglich
Behebung kleinerer Bugs

10.2010

V3.9.0

UDS-Check auf neue ZEDIS-Regeln angepasst
Testablauf erweitert um Sprung in andere Test-Datei
Behebung kleinerer Bugs

05.2009

V3.8.0

Argument-Assistent für die Zusammenstellung der Argumente von UDS Standard-Jobs
Zusätzliche Results anzeigen für UDS-Standard-Jobs (in der Job-Auswahl)
Filterung spezieller Result-Endungen für Ausgaben in Resultfenster
neue Funktion zur formalen Verifikation von UDS SGBDen
API.bas aktualisiert (Resultbuffer vergrößert (64k) für EDIABAS V7)
Umstellung auf HTML-Hilfe (*.chm)
Erweiterung Hilfe-Menü, Verlinkung PDFs
Bevorzugte Reihung der Tabellen SG_FUNKTIONEN und FORTTEXTE im TabellenFenster
Neu: Delay Funktion im Testablauf

09.2006

V3.4.2

Unterstützung UDS-Protokoll (ISO 14229)
Fehlerspeicher Lesen wie INPA
Fenster Tabellen-Info
Doppelklick auf eine Zelle
a) Zellen enthält den Namen einer anderen Tabelle -> Anzeige der so gewählten Tabelle;
mit den dann eingeblendeten Tasten kann zwischen den Tabellen navigiert werden
Schachteltiefe max. 10 Tabellen
b) Zelleninhalt als Attribut in Fenster Jobauswahl übernehmen
Attribut leer -> Spaltenüberschrift und Zelleninhalt werden übernommen
Attribut nicht leer -> wenn Attribut mit "<Spaltenüberschrift>;" beginnt, wird der Zelleninhalt hinzugefügt
Spaltenbreite in Tabellen
a) Begrenzung der max. Breite einer Spalte auf ca. 1/3 der Bildschirmbreite; kann später manuell verändert (auch verbreitert) werden
b) wenn der Spalteninhalt nicht vollständig angezeigt wird: Maus auf die betreffende Zelle positionieren, Zelleninhalt wird im ToolTip angezeigt
c) wenn Spalteninhalt in ToolTip nicht vollständig anzeigbar: Zelle selektieren,
Inhalt in Zwischenablage und in einem beliebigen Editor einfügen
Hinweis: ganze Spalten selektierbar, mit <Shift> Spaltenbereiche selektierbar
Auswahl einer Tabelle aus Fenster Job-Info
a) Doppelklick auf Tabellennamen ("..... table <tablename> <spalte1> <spalte2>" etc.)
in der Zeile muss das Keyword "Table" vor dem selektierten Text
(Select oder Dblclick möglich) stehen: Tabelle wird in Tabellen-Info angezeigt
b) stehen hinter dem Tabellennamen noch Spaltennamen, werden nicht aufgeführte Spalten minimiert dargestellt
Fenster Jobauswahl
Übernahme Argumente aus anderen Fenstern
a) aus einer Tabelle (siehe oben)
b) mit Drag&Drop aus anderen Text-Fenstern (z.B. Job-Info)
normal: markierter Text wird zum Argument
mit <Shift>: markierter Text wird an bestehendes Argument angehängt
Multiinstanz
Fenstergrößen, Fensterpositionen, letzte Attribute und zuletzt verwendete Dateien werden für jede Instanz getrennt gespeichert.
Applikationsparameter
Es werden zu jeder Instanz Größe und Position der Applikation gespeichert und wiederhergestellt.
Bei mehreren Monitoren wird nur der Hauptmonitor unterstützt!
Bei Multiinstanz=N wird immer mit Vollbild gestartet, Größe/Position erst nach dem Verkleinern.

04.2003

V3.2.3

32-Bit Version
Erweiterung Autoload für tst/prg/grp

01.2003

V3.0.0

32-Bit Version
Drucker neu dazu
Deutsch/English Version
Erweiterung der Hilfe

12.1997

V2.0.0

16-Bit und 32-Bit Version
Fehlerspeicher lesen wie INPA Umweltsätze neu dazu
Timerauflösung für ADS, KBUS in About neu
IfhTrace Level 1-4 neu dazu
Performancesteigerung bei Job-Information
Tabellen-Info neu dazu
Jobauswahl Suchfunktion neu dazu

02.1997

V1.2.0

Ausgabe der Job-Informationen bei ungestippten SGBD'en.
Pufferlisten zur Performancesteigerung integriert.
Resultausgabe sortiert (Standard) und in Resultlistenreihenfolge
EMEDIT.VBX durch EMEDIT2.VBX ersetzt.

07.1996

V1.1.1

Test-Trennzeichen jetzt '|' vorher ','

06.1996

V1.1.0

Editorbox neu (EMEDIT.VBX).
Ausgabeform für Tests geändert.
Jobfenster schließen jetzt möglich, damit die SGBD freigegeben wird
( Share-Fehler beim Compilieren ).

05.1996

V1.0.0

Freigegebene Version.


Tastaturbedienung

Grundsätzliche Windows Bedienung:

Strg F6 Strg TAB | Wechsel von einem Ausgabe-Fenster zum Nächsten
Strg Einfg | Kopieren eines markierten Bereiches in die Zwischenablage
Strg P | Drucken
Alt F4 | Beenden des Programms
Strg F4 | Schließen des Ausgabe-Fensters
Alt | Wechsel von Fenster zu Menüleiste

Menübedienung:

Alt D | Menüpunkt Datei
Alt J | Menüpunkt Job
Alt T | Menüpunkt Test
Alt K | Menüpunkt Konfiguration
Alt T T | Menüpunkt Trace
Alt F | Menüpunkt Fenster
Alt H | Menüpunkt Hilfe

Jobbedienung:

F3 | SGBD, Gruppendatei laden
Strg J | Wechsel ins Jobauswahl-Fenster
F5 | Job einmal ausführen
F6 | Job dauernd ausführen

Testbedienung:

Strg F3 | Test laden
Strg B | Wechsel ins Test-Fenster
F7 | Testschritt ausführen
F8 | Test ausführen

Konfigurationsbedienung:

Strg E | EDIABAS-Konfiguration
Strg T | EDIABAS ToolSet-Konfiguration


Übersicht

Klicken auf den entsprechenden Punkt im Bild.


Datei Menü

Klicken auf den entsprechenden Punkt im Bild.


SGBD, Gruppendatei laden

Laden einer Steuergerätebeschreibungsdatei bzw. Gruppendatei.

Eine Steuergerätebeschreibungsdatei wird an der Dateiextension '.PRG' erkannt und in die Datei Historie aufgenommen.

Eine Gruppendatei wird an der Dateiextension '.GRP' erkannt und in die Datei Historie aufgenommen.

Der EDIABAS ECU-Pfad wird dabei automatisch entsprechend geändert.

Beim Laden einer Gruppendatei wird die Variante ermittelt und die Jobs dieser Variante in der Jobauswahlliste angezeigt.

Die Jobs werden über die Gruppendatei aufgerufen.

Außerdem wird bei aktivierter EDIABAS Simulation automatisch die zugehörige Simulationsdatei geladen.

Die Simulationsdatei hat die Dateiextension '.SIM' und wird im EDIABAS Simulations-Pfad gesucht. Wird die Simulationsdatei nicht gefunden, wird eine entsprechende Meldung ausgegeben.


Simulationsdatei speichern

Speichern der Simulationsdatei.

Eine Simulationsdatei wird mit der Dateiextension '.SIM' als Textdatei im EDIABAS Simulations-Pfad abgespeichert.


Test neu

Erstellen eines leeren Testfensters.

Im Testfenster können einfache Testschrittfolgen bearbeitet und ausgeführt werden.


Test laden

Laden eines Testes in das Testfenster.

Ein Test wird an der Dateiextension '.TST' erkannt und in die Datei Historie aufgenommen.

Im Testfenster können einfache Testschrittfolgen bearbeitet und ausgeführt werden.


Test speichern

Speichern eines Tests.

Ein Test wird mit der Dateiextension '.TST' als Textdatei abgespeichert und in die Datei Historie aufgenommen.

Die Testdatei hat folgendes Format:

Jeder Testschritt wird durch eine neue Zeile erkannt.

Jeder Spalteneintrag wird durch '|' getrennt. Somit ist '|' kein gültiges Zeichen innerhalb eines Spalteneintrags. '|' am Ende einer Zeile sind nicht zwingend nötig.


Test speichen unter...

Speichern eines Tests.

Ein Test wird mit der Dateiextension '.TST' als Textdatei abgespeichert und in die Datei Historie aufgenommen.

Die Testdatei hat folgendes Format:

Jeder Testschritt wird durch eine neue Zeile erkannt.

Jeder Spalteneintrag wird durch '|' getrennt. Somit ist '|' kein gültiges Zeichen innerhalb eines Spalteneintrags. '|' am Ende einer Zeile sind nicht zwingend nötig.


UDS-Check

Der Menüpunkt ist anwählbar, wenn eine SGBD geladen ist, welche die Tabelle SG_FUNKTIONEN enthält.

Es erfolgt eine formale Überprüfung der Tabelle SG_FUNKTIONEN sowie deren Detailtabellen. Das Ergebnis der Überprüfung wird in das Resultfenster ausgegeben.

Beispiel für eine Überprüfung ohne Fehler:

================================

SGBD01: Start Prüfung

================================

Tabelle SG_FUNKTIONEN prüfen....

Tabelle existiert

Tabelle Header ok

Eindeutige Verwendung von ARG prüfen....

Plausibilität SG_FUNKTIONEN und Service-IDs prüfen....

================================

SGBD01: Ende Prüfung

================================

Im Fehlerfall werden die Fehlerquellen mit Tabellennamen und Zeilennummern ausgegeben.


UDS-Check Liste

Ermöglicht die Auswahl mehrerer SGBDen zur Überprüfung der formalen Kriterien.

Das Ergebnis der Überprüfung wird in das Resultfenster ausgegeben.

Dir Menüeintrag ist über eine Einstellung in der Konfigurationsdatei TOOL32.INI aktivierbar.

[KONFIGURATION]

UDS_CHECK_LISTE = 1


Drucker Info

Ausgabe auf den Drucker möglich aus den Fenstern:

· Result
· IFH Result
· Simulation
· Job-Info


Datei Historie

Die letzten 5 benutzten Steuergerätebeschreibungsdateien, Gruppendateien bzw. Testdateien werden in der Datei Historie vermerkt. Sie werden in der Datei TOOL32.INI im Windows-Verzeichnis gespeichert und stehen somit beim nächsten Programmstart wieder zur Verfügung.


Programm beenden

Hiermit wird das Programm beendet. Sollte eine geänderte Simulationsdatei oder ein geänderter Test noch offen sein, wird abgefragt, ob diese gespeichert werden sollen.


Job Menü

Klicken auf den entsprechenden Punkt im Bild.


Ecu Info

Information über die geöffnete Steuergerätebeschreibungsdatei durch den virtuellen EDIABAS Job _VERSION.


Jobauswahl

Klicken auf den entsprechenden Punkt im Bild.


Jobs

Jobauswahlliste aller in der SGBD verfügbaren Jobs.

Suchfunktion:

Die Jobauswahl kann mit den Cursor-Tasten bedient werden. Es ist eine automatische Suchfunktion eingebaut. Mit einem Tastendruck wird in ein Feld angezeigt, das die Suchmaske anzeigt. Mit Pfeil auf bzw. Pfeil ab kann von einem zum nächsten passenden Eintrag gesprungen werden. Mit jeder Eingabe wird automatisch überprüft, ob es einen passenden Eintrag gibt und zu diesem gesprungen. Wird kein Eintrag gefunden wird der Tastendruck nicht angenommen. Mit der Lösch-Taste kann die Maske Zeichenweise gelöscht werden. Die Entfernen-Taste oder die ESC-Taste löscht die Suchmaske komplett.


Arguments

Eingabefeld für die Argumente.

Argumente nicht vom Typ DATA:

Jedes Argument wird durch Strichpunkt ';' voneinander getrennt.

Mit der Enter-Taste wird das aktive Argument in die Argumentliste übernommen.

Sie werden in der Datei TOOL32.INI im Windows-Verzeichnis gespeichert und stehen somit beim nächsten Programmstart wieder zur Verfügung.

Argument vom Typ DATA:

DATA-Argumente werden als Hex-String übergeben: 2-stellig ohne Leerzeichen als Trennzeichen bzw. 1- oder 2-stellig mit Leerzeichen als Trennzeichen.

Beispiel Argument:

Arg1;Arg2;Arg3

Beispiel DATA Argument:

1234567890 => 5 Bytes 0x12 0x34 0x56 0x78 0x90

12 03 4 AB C => 5 Bytes 0x12 0x03 0x04 0xAB 0x0C


Job Data

Data

Ist das Argument vom Typ DATA muß dieses Feld aktiviert werden.


Argument Assistent

Die Taste "Löschen" leert die Eingabezeile für Argumente.

Die Taste "Argument Assistent" ist nur aktiv, wenn einer der 4 UDS Standard Jobs (STATUS_LESEN, STEUERN, STEUERN_IO oder STEUERN_ROUTINE) angewählt ist.

Der „Argument Assistent“ ermöglicht das komfortable Befüllen der Argumenten-Eingabezeile. Der Dialog ist ein modales Fenster, erst nach dem Schließen dieses Fensters können wieder andere Funktionen in EDIABAS ToolSet verwendet werden.

Der Dialog für STATUS_LESEN ermöglicht bei Aktivierung der Option "Merhrfachauswahl"die Auswahl mehrerer DIDs, welche in der Folge auch alle als Argumente übernommen werden. Bei der Anwendung dieser Option muss berücksichtigt werden, welche Anzahl von DIDs vom Steuergerät verarbeitet werden kann.

Taste "Übernahme": Schließt den Assistenten und übernimmt die gewählten Argumente in die Argumente-Zeile in der Jobauswahl.
Taste "Job ausführen": der Job wird mit den gewählten Argumenten sofort ausgeführt, der Assistent bleibt geöffnet.

Der Dialog für die STEUERN... –Jobs ermöglicht die Auswahl einer einzelnen DID und der Eingabe der weiteren zugehörigen Argumente.

Für digitale und diskrete Werte wird eine Auswahlbox angezeigt, für alle anderen Datentypen ein Eingabefeld.

Taste "Übernahme": Schließt den Assistenten und übernimmt die gewählten Argumente in die Argumente-Zeile in der Jobauswahl.
Taste "Job ausführen": der Job wird mit den gewählten Argumenten sofort ausgeführt, der Assistent bleibt geöffnet.

Zusätzliche Hinweise:

Anzeige des Inhaltes der Spalte Info (der jeweiligen angewählten Zeile) als Hinweistext

Farbumschlag, wenn Wertgrenzen oder Min/Max verletzt bzw. Argument nicht befüllt ist. Dies ist als Hinweis zu verstehen, eine endgültige Prüfung des Argumentes erfolgt dann in Standard-Job und Steuergerät.

Aufgrund von Wertprüfungen rot hinterlegte Felder verhindern nicht die Übernahme.

Beim Öffnen des Fensters wird versucht, mit dem aktuellen Inhalt der Argumenten Eingabezeile die Parameter vorzubelegen.

Für den Job STEUERN_ROUTINE werden die Argumente anhand des Steuerparameters gefiltert.


Argument-Information

Falls die SGBD nicht gestrippt ist, und in der Konfiguration der Punkt Argument-Information ein ist, wird hier bei Job's mit Argumenten die Argument-Information angezeigt. Detaillierte Informationen zum Job können der Job-Information entnommen werden.


Results

Wenn die SGBD nicht gestrippt ist, steht eine Resultauswahlliste zur Verfügung mit der die einzelnen Results angefordert werden können. Wird keines angewählt werden alle Results angefordert.

Wenn die SGBD gestrippt ist, steht ein Eingabefeld für die Results zur Verfügung. Jedes Result wird durch Strichpunkt ';' voneinander getrennt.

Mit der Enter-Taste wird das aktive Result in die Resultliste übernommen.

Sie werden in der Datei TOOL32.INI im Windows-Verzeichnis gespeichert und stehen somit beim nächsten Programmstart wieder zur Verfügung.

Wenn einer der 4 UDS Standardjobs (STATUS_LESEN, STEUERN, STEUERN_IO oder STEUERN_ROUTINE) angewählt ist, werden anhand des Inhaltes der Agumentzeile die zu generierenden Results ermittelt. Diese werden unter den "echten" Results des Jobs zusätzlich aufgelistet. Die Selektion dieser Results hat keine Auswirkung (werden beim Jobaufruf nicht als Argument übergeben).


Job einmal ausführen

Starten eines im Jobauswahlfenster angewählten Jobs. Die Ergebnisse bzw. eine EDIABAS Fehlermeldung wird im Resultfenster ausgegeben.


Job dauernd ausführen

Dauerndes Ausführen eines im Jobauswahlfenster angewählten Jobs. Die Ergebnisse bzw. eine EDIABAS Fehlermeldung werden im Resultfenster ausgegeben bzw. aktualisiert.

Durch ein erneutes Betätigen wird die Ausführung gestoppt.

Nach einer kurzen Zeit wird die mittlere Jobabarbeitungszeit im Resultfenster angegeben.

Im Result-Fenster wird ein Anzeigebalken eingeblendet, mit dem eine Verzögerung zwischen den Diagnoseaufrufen einstellbar ist. Der Balken wird wieder ausgeblendet, wenn die Ausführung gestoppt wird. Der eingestellte Wert bleibt im Hintergrund erhalten, hat aber keine Wirkung bei 'Job einmal ausführen'.


Test Menü

Klicken auf den entsprechenden Punkt im unteren Bild.


Test bearbeiten

Beispiel

Klicken auf den entsprechenden Punkt im Bild.


Beispiel

Nr | n | SGBD | JOB | (data) | ARGUMENT | RESULT | (view) | L:Name | L:Wert | L:Ja | L:Nein
1 | 1 | IHKA39 | IDENT |  |  |  |  |  |  |  |
2 | 1 | IHKA39 | IDENT |  |  |  | nein | JOB_STATUS | OKAY | 3 | 2
3 | 1 |  |  |  |  | JOB_STATUS |  |  |  | 5 |
4 |  |  |  |  |  |  |  |  |  |  |
5 | 5 | IHKA39 | FS_LESEN |  |  | F_ORT_NR |  |  |  |  |
6 | 1 | IHKA39 | IDENT |  |  |  |  | ID_BMW_NR | 123456 | XYZ |
7 | 3 |  | &delay |  | 1500 |  |  |  |  |  |
8 | 1 | UTILITY | STATUS_UBATT |  |  | UBATT | nein | UBATT | 0 | 8 |
9 | 1 | IHAK39 | RAM_LESEN |  | 0x00;32 |  |  |  |  |  |
10 | 1 | IHKA39 | SCHREIBE | ja | 0110CA | JOB_STATUS |  |  |  |  |
Zeile 1 | Es wird der Job Ident aus IHKA39.PRG einmal aufgerufen.
Zeile 2 | Es wird der Job Ident aus IHKA39.PRG einmal aufgerufen. Es erfolgt keine Ausgabe im Ergebnisfenster. Wenn Job_Status='OKAY' dann weiter mit Zeile 3 sonst bleibe in Zeile 2.
Zeile 3 | Es wird kein Job aufgerufen, aber es wird das Ergebnis Job_Status geholt. Es erfolgt die Ausgabe im Ergebnisfenster. Unbedingter Sprung in Zeile 5.
Zeile 4 | Hier passiert gar nichts.
Zeile 5 | Es wird der Job Fs_Lesen aus IHKA39.PRG fünfmal aufgerufen. Es wird das Ergebnis F_Ort_Nr geholt. Es erfolgt die Ausgabe im Ergebnisfenster.
Zeile 6 | Es wird der Job Ident aus IHKA39.PRG einmal aufgerufen. Es erfolgt die Ausgabe im Ergebnisfenster. Wenn ID_BMW_NR='123456' dann wird der Test "XYZ.TST" geladen, weiter in Zeile 1, sonst weiter in Zeile 7 (ohne Wechsel)
Zeile 7 | Hier wird eine Pause eingelegt. Wartezeit = 3 * 1500 ms, also insgesamt 4,5 Sekunden.
Zeile 8 | Es wird der Job Status_Ubatt aus UTILITY.PRG einmal aufgerufen. Es wird das Ergebnis Ubatt geholt. Es erfolgt keine Ausgabe im Ergebnisfenster. Wenn Ubatt='0' dann bleibe in Zeile 8 sonst springe in Zeile 9.
Zeile 9 | Es wird der Job Ram_Lesen aus IHKA39.PRG einmal aufgerufen. Es werden zwei Argumente 0 und 32 übergeben. Es erfolgt eine Ausgabe im Ergebnisfenster.
Zeile 10 | Es wird der Job Schreibe aus IHKA39.PRG einmal aufgerufen. Es werden drei Byte 0x02 0x10 0xCA vom Typ DATA als Argument übergeben. Es wird das Ergebnis Job_Status geholt. Es erfolgt eine Ausgabe im Ergebnisfenster.


Eingabezeile

Eingabezeile für das in der Testmatrix aktiven Feld.


Nr

Testschritt

Zeilennummer für einen Testschritt. Sie dient als Sprungziel für L: Ja bzw. L: Nein.


n

Anzahl der Durchläufe für diesen Testschritt.


SGBD

Name der Steuergerätebeschreibungsdatei bzw. Gruppendatei. Es wird auf das aktuelle EDIABAS ECU-Verzeichnis zugegriffen.

Vorsicht:

Das Laden einer SGBD verändert eventuell das EDIABAS ECU-Verzeichnis!


Test Job

JOB

Name des aufzurufenden Jobs


(data)

Wenn Argumente vom Typ DATA übergeben werden muß hier 'ja' stehen ( default ist nein="").

Ein Wechsel der Eingabe erfolgt durch die Leer-Taste.


ARGUMENT

Zu übergebende Argumente.

Die Argumente werden durch Strichpunkt ';' getrennt.

Soll das Argument vom Typ DATA sein, muß das Feld (data) auf 'ja' stehen.

DATA-Argumente werden als Hex-String übergeben: 2-stellig ohne Leerzeichen als Trennzeichen bzw. 1- oder 2-stellig mit Leerzeichen als Trennzeichen.

Beispiel Argument:

Arg1;Arg2;Arg3

Beispiel DATA Argument:

1234567890 => 5 Bytes 0x12 0x34 0x56 0x78 0x90

12 03 4 AB C => 5 Bytes 0x12 0x03 0x04 0xAB 0x0C


RESULT

Namen der angeforderten Ergebnisse

Die angeforderten Ergebnisse werden durch Strichpunkt ';' getrennt.

Wird kein Result angegeben werden alle Ergibnisse angefordert.

Beispiel Result:

Result1;Result2;Result3


(view)

Wenn die Ergebnisse nicht im Ergebnisfenster erscheinen sollen muß hier 'nein' stehen ( default ist ja="").

Ein Wechsel der Eingabe erfolgt durch die Leer-Taste.

Vorsicht:

Das Ergebnisfenster sollte nicht zu groß werden, denn dadurch wird der Programmlauf immer langsamer.

Wenn ein Testschritt mehrfach durchlaufen wird, sollte die Ausgabe auf 'nein' stehen. Statt dessen könnte der Api-Trace bzw. IFH-Trace eingeschaltet werden.


Logik Name

L: Name

Name des RESULTS für den Logikvergleich.

Wird kein L: Name angegeben wird auch kein Vergleich durchgeführt.

Die Spalten L: Name, L: Wert, L: Ja, L: Nein dienen der Testschrittsteuerung mit folgender Logik:

if L:Name = "L:Wert" then goto L:Ja else goto L:Nein


Logik Wert

L: Wert

Textstring der mit dem Inhalt von L: Name verglichen wird.

Wird kein L: Name angegeben wird auch kein Vergleich durchgeführt.

Die Spalten L: Name, L: Wert, L: Ja, L: Nein dienen der Testschrittsteuerung mit folgender Logik:

if L:Name = "L:Wert" then goto L:Ja else goto L:Nein


Logik Ja

L: Ja

Ist der Vergleich vom Inhalt von L: Name mit L: Wert wahr wird in die Testzeile L: Ja gesprungen.

Ist L: Ja nicht belegt wird in die nächste Zeile gesprungen.

Wird kein L: Name angegeben wird auch kein Vergleich durchgeführt. Somit wird ohne Bedingung in die Testzeile L: Ja gesprungen.

Die Spalten L: Name, L: Wert, L: Ja, L: Nein dienen der Testschrittsteuerung mit folgender Logik:

if L:Name = "L:Wert" then goto L:Ja else goto L:Nein


Logik Nein

L: Nein

Ist der Vergleich vom Inhalt von L: Name mit L: Wert nicht wahr wird in die Testzeile L: Nein gesprungen.

Ist L: Nein nicht belegt wird in die nächste Zeile gesprungen.

Wird kein L: Name angegeben wird auch kein Vergleich durchgeführt. Somit wird ohne Bedingung in die Testzeile L: Nein gesprungen.

Die Spalten L: Name, L: Wert, L: Ja, L: Nein dienen der Testschrittsteuerung mit folgender Logik:

if L:Name = "L:Wert" then goto L:Ja else goto L:Nein


Testmatrix

Im Testmatrixeingabefeld sind verschiedene Steuermöglichkeiten:

1) Positionieren auf ein Testschrittfeld mittels Maus-Klick oder Cursor-Tasten. Das aktivierte Testschrittfeld wird im Prüfschrittfeld links oben angezeigt.

2) Verändern der Spaltenbreite bzw. Spaltenhöhe mittels Maus-Ziehen über der ensprechenden Spaltenmarkierung in der ersten Zeile bzw. über der entsprechenden Zeilenmarkierung in der ersten Spalte.

Es findet außerdem eine automatische Spaltenbreiteanpassung bei der Eingabe statt.

3) Markieren mehrerer Testschrittfelder mittels Maus-Ziehen über den Entsprechenden Testschrittspalten und Testschrittzeilen.

Der Markierte Bereich kann mit den Tasten

Strg-Einfg in die Zwischenablage kopiert werden,

Umsch-Entf gelöscht und in die Zwischenablage kopiert werden,

Umsch-Einfg aus der Zwischenablage kopiert werden.


Testschritt ausführen

Ausführen des im Testfenster angewählten Testschritts. Die Ergebnisse bzw. eine EDIABAS Fehlermeldung wird im Resultfenster ausgegeben.


Test ausführen

Ausführen des im Testfenster stehenden Tests. Die Ergebnisse bzw. eine EDIABAS Fehlermeldung werden im Resultfenster ausgegeben.

Durch ein erneutes Betätigen wird die Ausführung gestoppt.


Konfiguration Menü

Klicken auf den entsprechenden Punkt im Bild.


EDIABAS Konfiguration

Klicken auf den entsprechenden Punkt im Bild.


EDIABAS Konfiguration Nicht veränderbare Informationen

EDIABAS Konfiguration

Nicht veränderbare Informationen:

EDIABAS | EDIABAS Version
IFH | Interface Handler Version
Interface | Interface Hardware
BIP | Level Best Interpreter Debuglevel
Pfade |
Ini | Pfad der EDIABAS.INI Datei
ECU | Pfad für die SGBD '.PRG' und Gruppendateien '.GRP'
Sim | Pfad für die Simulationsdateien '.SIM'
Trace | Pfad für die Tracedateien IFH.TRC


EDIABAS Konfiguration Veränderbare Optionen

EDIABAS Konfiguration

Veränderbare Optionen:

Simulation | Simulationsmode Ein / Aus
IfhTrace | Interface Trace Ein / Aus (Bei eingeschaltenem Trace Eingabe des Trace-Levels 1- 4)
RetryComm | Fehlerwiederholzähler Ein / Aus
SystemResults | Systemergebnisse im Satz 0 Ein / Aus
UbattHandling | Batteriefehler Behandlung Ein / Aus
IgnitionHandling | Zündungsfehler Behandlung Ein / Aus


EDIABAS ToolSet Konfiguration

Klicken auf den entsprechenden Punkt im Bild.


EDIABAS ToolSet Konfiguration Allgemeine Optionen

EDIABAS ToolSet Konfiguration

Allgemeine Optionen:

Toolbar | Toolbaranzeige Ein / Aus
Kopfzeile | Kopfzeilenanzeige Ein / Aus
Hinweiszeile | Hilfe-, Hinweiszeile Ein / Aus


EDIABAS ToolSet Konfiguration Sprachauswahl

EDIABAS ToolSet Konfiguration

Sprachauswahl

Language0 | Deutsch
Language1 | Englisch


EDIABAS ToolSet Konfiguration Ausgabe Optionen

EDIABAS ToolSet Konfiguration

Ausgabe Optionen:

Ausgabe sortiert | Resultausgabe sortiert Ein / Aus Die Ergebnisse werden sortiert (EDIABAS-Standardausgabe) oder in der Reihenfolge der Resultliste ausgegeben.
FS-Lesen wie INPA | FS_LESEN im INPA-Format Ein / Aus INPA: Interpreter für Prüfabläufe ist eine EDIABAS-Applikation für die Nacharbeit in den Werken


EDIABAS ToolSet Konfiguration Informations Optionen

EDIABAS ToolSet Konfiguration

Informations Optionen:

Job-Informationen | Job-Informationsfenster Ein / Aus Die Job-Informationen sind nur bei ungestrippten SGBD'en verfügbar.
Argument- Informationen | Argument-Information Ein / Aus Die Job-Informationen sind nur bei ungestrippten SGBD'en verfügbar.
Result- Informationen | Result-Liste Ein / Aus Die Result-Informationen sind nur bei ungestrippten SGBD'en verfügbar.
Tabellen- Informationen | Tabellen-Informationsfenster Ein / Aus


EDIABAS ToolSet Konfiguration INPA Fehlerspeichermode

EDIABAS ToolSet Konfiguration

INPA Fehlerspeichermode:

Wenn die Option FS-Lesen wie INPA aktiviert ist, kann hier die Anzeigeform wie in INPA modifiziert werden.

Fehlerort | Ein / Aus
PCode und PCode7 | Ein / Aus (nur für BN2000)
SAECode | Ein / Aus (nur für UDS)
Fehlerhäufigkeit | Ein / Aus
Fehlerart | Ein / Aus
Umweltbedingung Wert Einheit | Ein / Aus Ein / Aus Ein / Aus
Fehler HexCode | Ein / Aus


EDIABAS ToolSet Konfiguration UDS Ausgabe Optionen

EDIABAS ToolSet Konfiguration

UDS Ausgabe Optionen:

Über Abwahl der Checkboxen kann die Anzeige von Results mit bestimmten Endungen unterbunden werden. Dadurch kann nach der Job Ausführung die Darstellung der Results im Anzeige im Resultfenster übersichtlicher werden.

Für Results mit folgenden Endungen kann die Ausgabe unterbunden werden:

_EINH | Ein / Aus
_INFO | Ein / Aus
_TEXT | Ein / Aus


Trace Menü

Klicken auf den entsprechenden Punkt im Bild.


IFH Trace anzeigen

Anzeige der IFH ( InterFaceHandler ) Trace-Datei.

Sie wird im EDIABAS Trace-Pfad unter dem Namen IFH.TRC gesucht.

Die Datei kann nur angesehen werden, wenn der EDIABAS IFH Trace-Mode nicht aktiviert ist.


IFH Trace löschen

Löschen der IFH ( InterFaceHandler ) Trace-Datei.

Sie wird im EDIABAS Trace-Pfad unter dem Namen IFH.TRC gesucht.


Fenster Menü

Klicken auf den entsprechenden Punkt im Bild.


Fenster überlappend

Alle geöffneten Fenster werden überlappend dargestellt. Nachdem einige Fenster feste Mindestgrößen haben kann es vorkommen, daß nicht alle Fenster die selbe Größe haben.


Fenster untereinander

Alle geöffneten Fenster werden untereinander dargestellt. Nachdem einige Fenster feste Mindestgrößen haben kann es vorkommen, daß die Fenster sich zum Teil überlappen.


Fenster nebeneinander

Alle geöffneten Fenster werden nebeneinander dargestellt. Nachdem einige Fenster feste Mindestgrößen haben kann es vorkommen, daß die Fenster sich zum Teil überlappen.


Symbole anordnen

Alle Symbole werden am unteren Fensterrand neu angeordnet.


Result-Fenster

Anzeigefenster für Tests oder Jobs.

Bei 'Jobs dauernd ausführen' wird im Fenster wird ein Anzeigebalken eingeblendet, mit dem eine Verzögerung zwischen den Diagnoseaufrufen einstellbar ist. Der Balken wird wieder ausgeblendet, wenn die Ausführung gestoppt wird. Der eingestellte Wert bleibt im Hintergrund erhalten, hat aber keine Wirkung bei 'Job einmal ausführen'.

Das Fenster kann nicht editiert werden.

Es ist jedoch möglich Information mittels markieren und der Tastenkombination Strg-Einfg in die Zwischenablage zu kopieren.

Abhängig von den Einstellung in der EDIABAS ToolSet Konfiguration können die dargestellten Results gefiltert dargestellt sein. Results mit bestimmten Endungen werden dann nicht aufgelistet. Ist der Filter aktiv, wird dies durch eine Hinweiszeile am Ende des Result Fensters kenntlich gemacht.


Tabellen-Information

In diesem Fenster wird die verfügbare Tabellen-Information angezeigt.

Eine der verfügbaren Tabellen kann in der Auswahlliste angewählt werden.

Mit der Entf-Taste kann die aktive Tabellenspalte ausgeblendet werden.

Mit der Einfg-Taste kann die aktive Tabellenspalte wieder angezeigt werden.

Das Fenster kann nicht editiert werden.

Es ist jedoch möglich Information mittels markieren und der Tastenkombination Strg-Einfg in die Zwischenablage zu kopieren.

siehe auch Job-Information


Job-Information

In diesem Fenster wird die verfügbare Job-Information angezeigt. Sie enthält keine Informationen über Results, Arguments und Kommentare wenn die Datei gestrippt ist.

Verweist ein Kommentar in folgender Form auf eine Tabelle: table TabellenName TabellenSpalte

so wird mit einem Doppel-Click auf TabellenName das Tabellen-Information-Fenster mit der entsprechenden Tabelle und TabellenSpalte angezeigt.

Das Fenster kann nicht editiert werden.

Es ist jedoch möglich Information mittels markieren und der Tastenkombination Strg-Einfg in die Zwischenablage zu kopieren.


Simulations-Datei

In diesem Fenster wird die Simulations-Datei angezeigt.

Das Fenster kann editiert werden.

Mit der Einfg-Taste kann zwischen Einfügemodus und Überschreibmodus gewechselt werden.

Mit der Taste F2 wird die Datei abgespeichert.

Vorsicht:

EDIABAS greift grundsätzlich auf die Simulationsdatei zu. Änderungen müssen daher zuerst gespeichert werden.


Trace-Datei

In diesem Fenster wird die Trace-Datei angezeigt.

Das Fenster kann nicht editiert werden.

Es ist jedoch möglich Information mittels markieren und der Tastenkombination Strg-Einfg in die Zwischenablage zu kopieren.

Vorsicht:

Die Trace-Datei kann nur angezeigt werden, wenn der IFH-Trace ausgeschaltet ist.


Hilfe Menü

Klicken auf den entsprechenden Punkt im Bild.


Hilfe

Damit kommen Sie in diese Hilfe.


EDIABAS Dokumentation

Über das Hilfe Menü können folgende Dateien im PDF Format geöffnet werden:

· Anleitung_STATUS_STEUERN_UDS.pdf
· FAQ.pdf

Voraussetzung dafür ist die Installation des Acrobat Readers.

Die Menüpunkte sind anwählbar, wenn die Datei im Verzeichnis \..\doku\deutsch\ vorhanden ist.

Die Adressierung von \..\doku\deutsch\ erfolgt relativ zum EDIABAS\bin Verzeichnis, daraus muss auch TooSet gestartet werden.

Beispiel für einen den vollständigen Pfad: C:\EDIABAS\DOKU\Deutsch


Was ist neu?

Über das Hilfe Menü kann die Datei Tool32_News.pdf geöffnet werden:

Voraussetzung dafür ist die Installation des Acrobat Readers.

Der Menüpunkt ist anwählbar, wenn die Datei im selben Verzeichnis liegt, von dem aus EDIABAS ToolSet gestartet wird.

Die Datei enthält in der Regel Informationen zu den zuletzt durchgeführten Änderungen und Bugfixes.

Darunter auch Informationen, die nicht in der Online-Hilfe dokumentiert sind.


EDIABAS Hilfe

Über das Hilfe Menü kann die EDIABAS Hilfe geöffnet werden:

Der Menüpunkt ist anwählbar, wenn die Datei \..\doku\html\index.html vorhanden ist.

Die Adressierung erfolgt relativ zum EDIABAS\bin Verzeichnis, daraus muss auch EDIABAS ToolSet gestartet werden.

Beispiel für einen den vollständigen Pfad: C:\EDIABAS\DOKU\html\index.html


About

Hier wird die About Info ausgegeben.


INI Datei

INTERFACExx = Interface,Unit,Application,Configuration

MULTIINSTANZ = N (NO,Nein oder andere Zeichen außer 'Y' or 'J' )

MULTIINSTANZ = J oder Y (YES,Ja)

LANGUAGE = D oder andere Zeichen außer 'E' für Deutsch

LANGUAGE = E für Englisch

[KONFIGURATION]

INTERFACE01 =

INTERFACE02 = STD:OMITEC,,,

INTERFACE03 = STD:OBD,3,,

INTERFACE04 =

INTERFACE05 =

INTERFACE06 =

INTERFACE07 =

INTERFACE08 =

INTERFACE09 = ENET,,,REMOTEHOST=169.254.99.99

MULTIINSTANZ = N

LANGUAGE = D


Kommandozeile

Das Programm gibt keine Rückmeldung über den Erfolg oder Mißerfolg der Ausführung zurück!

EDIABAS ToolSet Script -Ausführung über CASCADE mit TRACE-Aufzeichnung

Aufruf der Auswertung in CASCADE ist:

"TOOL32 <TEST_FILE > <API-Trace-Level> <IFH-Trace-Level>"

1. Der Parameter <TEST_FILE> mit Pfad muß auf das *.tst File im ECU-Verzeichnis zeigen

2. Der Parameter <API-Trace-Level> (0-4), 0 = Kein Trace (Standard ist 1)

3. Der Parameter <IFH-Trace-Level> (0-4), 0 = Kein Trace (Standard ist 2)

Das EDIABAS ToolSet startet automatisch mit der angegebenen Datei, führt den TEST durch und schließt nach Beendigung das Programm.

EDIABAS ToolSet mit Interface-Parametern

Das Ediabas-Toolset bietet die Möglichkeit Interface-Parameter beim Aufruf festzulegen.

Format: "TOOL32 -INTERFACExx = Interface,Unit,Application,Configuration"

xx steht für die Interfacenummer 01 bis 09, Details zu Interface, Unit, Application und Configuration siehe apiInitExt in der Ediabas Dokumentation.

Beispiel:
TOOL32 -INTERFACE03 = STD:OBD,3,,
Es wird das Interface OBD verwendet, in der OBD.INI werden die Parameter aus Abschnitt 3 verwendet.

Hinweis: Bei Verwendung dieser Option werden in der TOOL32.INI im Abschnitt [KONFIGURATION] folgende Einträge gesetzt oder verändert:
* MULTIINSTANZ wird auf den Wert "J" gesetzt
* Interface Parameter werden im Eintrag INTERFACExx gespeichert