Historie

Datum | Autor | Änderung
31.07.2003 | Georg Rauter | Erstellung
01.08.2003 | Georg Rauter | Links für direkten Aufruf der Web-Seiten (2x)
20.11.2003 | Georg Rauter | Funktionserweiterungen NFS Version 4.3.x
14.01.2004 | Georg Rauter | Anpassung GIS-Installation, Kommandozeile
27.09.2004 | Georg Rauter | Funktionserweiterungen NFS Version 4.5.x
05.10.2004 | Georg Rauter | Funktionserweiterungen für Motorrad Berlin
10.10.2007 | Georg Rauter | Änderungen für OPPS ab Firmware V6.25
01.10.2009 | Georg Rauter | Anpassung Kontakte und Kommandozeilenparameter


Bedienung dieser Hilfe

Die Online-Hilfe ist als schnelles (lokal verfügbare) Nachschlagewerk für Systembetreuer und Bediener konzipiert, ersetzt jedoch nicht die umfangreichere Dokumentation im PDF-Format.

Aus der Bedienoberfläche von NFS sind die Formulare, Menüs und Tasten kontextsensitiv verlinkt. Wenn der Fokus auf einem der genannten Elemente ruht und <F1> betätigt wird, erscheint automatisch die Hilfe mit dem zugeordneten Thema.

Die Grafiken der Menüs und einiger Formulare sind in der Hilfe mit Hotspots ausgestattet, mit einem Klick auf den entsprechenden Bereich in der Grafik wird automatisch zum zugeordneten Thema verzweigt.

Wenn eine Navigation zwischen gleichartigen Themen (z.B. den Einträgen eines Menüs) möglich ist, werden die Tasten "<<" und ">>" eingeblendet. Die Taste "Inhalt" schlägt immer das Inhaltsverzeichnis der Hilfe auf, die Taste "Index" bietet Schlüsselworte zur Verzweigung auf zugeordnete Themen an.

Einstieg zu wichtigen Themen:

Dokumentation

Bedienung Hauptfenster

Konfigurationsbeispiele

Referenz


Dokumentation

Mit der Installation von EDIABAS und NFS werden die entsprechenden Dokumente und Online-Hilfen automatisch auf dem Zielrechner abgelegt. Zum Ansehen der Dokumente im PDF-Format wird das Programm "Acrobat Reader" benötigt.

Datei | Englisch | Beschreibung
c:\ediabas\doku\deutsch\inhalt.pdf | c:\ediabas\doku\english\contents.pdf | Übersicht und Links auf alle relevanten Dokumente
..\doku\nfs.pdf | ..\doku\nfs_e.pdf | Informationen zum Einsatz und Betrieb von NFS (dieses Dokument)
..\doku\nfs_faq.pdf | ..\doku\nfs_faq.pdf | Antworten auf häufige Fragen zu NFS (deutsch und englisch)
..\doku\handb-winkfpt32_v1.3.pdf | <nicht verfügbar> | Informationen zum vom NFS verwendeten Flash-Tool
.\nfs.chm | .\nfs_e.chm | Online-Hilfe zu NFS (diese Hilfe-Datei)
.\winkfpt.hlp | <nicht verfügbar> | Online-Hilfe zu WinKFP

Anmerkung: Angabe der Pfade relativ zum NFS\bin Verzeichnis.


Fragen und Antworten

Die Antworten auf aufgetretene Fragen oder Probleme sind im Dokument NFS_FAQ.pdf zusammengefasst. Es ist geplant, dieses zweisprachige Dokument den Anforderungen entsprechend häufiger zu pflegen und zu aktualisieren.

Siehe auch:

Dokumentation


Ansprechpartner

Für Fragen oder Probleme, die nicht durch die Dokumentation, diese Online-Hilfe oder die in Fragen und Antworten zusammengefassten Lösungen beantwortet werden bzw. gelöst werden können, stehen bei BMW Ansprechpartner zur Verfügung.

Thema | Name (eMail) | Abt. | Telefon
NFS (Installation, Betrieb, Updates) | Reinhold Drexel ( reinhold.drexel@bmw.de ) | TI-538 | +49-89-382-44236
EDIABAS | EDIABAS Hotline ( referenz@bmw.de ) |  | +49-89-382-68878
WinKFP | Flash-Service ( flash.service@bmw.de ) |  | +49-89-382-61664


Installation und Update

Die Installation aller für NFS erforderlichen Komponenten erfolgt ausschließlich über den GIS-Server (Global Information Service). Um die Funktionen des GIS-Servers nutzen zu können, ist eine entsprechende Zulassung erforderlich.#

Der Zugriff erfolgt über das Forum "BMW Standard Tools Werk". NFS befindet sich in den Verzeichnissen "Standard Tools | Tool Installation Werk | NFS".

Weiterführende Informationen über GIS können über die GIS Homepage (http://gis.muc) abgerufen werden. Die Zulassung kann über die Homepage beantragt werden.

Individualisierung

Durch verschiedene Einstellmöglichkeiten in der Konfigurationsdatei kann die Oberfläche an die spezifischen Erfordernisse angepasst werden. Die wichtigsten Einstellmöglichkeiten sind:

·Einstellen der Sprache

·Wahl des Unternehmenslogos

·Ausblenden von Kopfzeile und/oder Klemmenstatus


Bedienung Hauptfenster

Mehr Informationen zum Hauptfenster

Menüs

Anzeigen

Tasten

Ampel und Signalleuchte


Hauptfenster Menüs

Zurück zu:

Bedienung Hauptfenster

Menüs, die zur Bedienung zur Auswahl stehen:

Datei

Extras

Notfallflashen

Konfiguration (nur sichtbar im Trailermodus)

TestMode

Hilfe


Hauptfenster Anzeigeelemente

Zurück zu:

Bedienung Hauptfenster


Hauptfenster Tasten

Zurück zu:

Bedienung Hauptfenster

Die Tasten sind nur sichtbar bzw. freigegeben wenn die Bedienung im Ablauf sinnvoll ist. So ist z.B. in obiger Grafik die Taste "Ignorieren" nicht sichtbar.

Tasten, die zur Bedienung zur Auswahl stehen:

Start

Weiter

Abbruch

Ignorieren

Drucken


Ampel und Signalleuchte

Zurück zu:

Bedienung Hauptfenster

(Ampel Ein)

Folgende Zustände des Ampel-Symbols sind möglich:

Ampelanzeige | Beschreibung
Ampel Aus | Signalisiert im Wechsel mit Ampel Ein, dass das Programm aktiv ist.
Ampel Ein | s.o.
Ampel Rot | Signalisiert einen Fehler im Programmablauf, der zwingend einen Abbruch zur Folge hat.
Ampel Gelb | Signalisiert einen Fehler im Programmablauf. Zu einem späteren Zeitpunkt im Ablauf entscheidet sich, ob dadurch ein Abbruch erforderlich wird. Die Ampel wechselt dann (ohne Bedienereingriff) entweder auf Rot oder Grün.
Ampel Grün | Signalisiert einen fehlerfreien Programmablauf

Signalleuchten

Für das Trailer-Flashen ist die Visualisierung des momentanen Ablaufstatus mittels Signalleuchten vorgesehen. Die Ansteuerung erfolgt dabei über die parallelen Ports des Rechners.

Folgende Signalleuchtenzustände sind möglich:

Signalleuchte | Beschreibung
Aus | Programmierung läuft oder Programm inaktiv Anmerkung: Eine Signalisierung erfolgt nur dann, wenn eine Aktion des Bedieners erforderlich ist. Deshalb kann aufgrund der Signalleuchte nicht unterschieden werden, ob das Programm inaktiv ist oder die Programmierung läuft.
Rot | Es ist ein Fehler aufgetreten, Bedieneingabe erforderlich.
Gelb | Anweisung, Bedieneingabe erforderlich.
Grün | Ergebnis i.O., das Steuergerät kann entnommen werden.


Bedienung Anzeigefenster

Zurück zu:

Bedienung Hauptfenster

Zum Menü mit Klick auf die Grafik!

Im Ausgabefenster wird der Inhalt einer zuvor (in der Regel aus dem Extras-Menü des Hauptfensters) ausgewählten Textdatei angezeigt. Optional kann der Inhalt der Datei geändert und wieder gespeichert werden. In der Regel dient die Anzeige der Inhalte der Information des Systembetreuers. Änderungen an den Dateiinhalten dürfen nur vom zuständigen Systembetreuer vorgenommen werden.

Achtung: Willkürliche Änderungen in den Dateien können dazu führen, das das NFS nicht mehr funktionsfähig ist.

Im Anzeigefenster sind die nachfolgend aufgeführten Anzeigeelemente enthalten:

Element | Beschreibung
Fenstertitel | Im Titel des Fensters wird der Name der dargestellten Datei angezeigt.
Änderungskennung | Wurde der Inhalt der angezeigten Datei geändert, wird dem Namen der Datei ein "*" hintangestellt.
Statusinfos | Werden nur dargestellt, wenn der Editmodus eingeschaltet ist. Beinhaltet die Nummer der Zeile in der sich der Cursor befindet und den Modus der Texteingabe (Überschreiben oder Einfügen)
Menü | Dateimenü (siehe nachfolgende Beschreibung)
Anzeigebereich für Dateiinhalt | In diesem Bereich wird der Inhalt der Datei dargestellt und im Edit-Modus geändert.


Bedienung Auswahlfenster

Zurück zu:

Bedienung Hauptfenster

Das Auswahlfenster wird nur beim Notfallflashen angezeigt. Dem Bediener wird eine Liste von Steuergeräten und ZB-Nummern angeboten, aus denen er einen Eintrag auswählt.

Der Taster "OK" wird erst sichtbar, wenn eine 17-stellige Fahrgestellnummer eingegeben und eines der in der Liste angebotenen Steuergeräte ausgewählt wurde.

Hinweis: In der Datei NOTFALL.DAT ist hinterlegt, welche Steuergeräte für das Notfallflashen zur Auswahl angeboten werden.


Bedienung About-Dialog

Zurück zu:

Bedienung Hauptfenster

Anmerkung: Die Historie ist nur sichtbar, wenn die Deutsche Sprache voreingestellt ist.


Bedienung Meldungsdialog

Zurück zu:

Bedienung Hauptfenster

Mit dem Meldungsdialog wird entweder der Bediener über unvorhergesehene Ereignisse informiert oder aber aufgefordert eine Entscheidung zu treffen.

Der Meldungsdialog ist ein modales Fenster, das heißt der Programmablauf wird so lange angehalten, bis der Bediener den Dialog quittiert.

Im folgenden Beispiel muss der Bediener entscheiden, ob die durchgeführten Änderungen gespeichert oder verworfen werden.

Im Normalablauf sollte der Meldungsdialog nie erscheinen. In der Regel wird der Meldungsdialog dann verwendet den Bediener zu informieren, wenn unvorhergesehene Probleme eine Fortsetzung des Programmablaufes unmöglich machen. Solche Probleme sind z.B.

·Fehler bei Dateioperationen

·Parameterdateien nicht vorhanden

·Parameterdateien im falschen Format können nicht interpretiert werden

·Fehler beim Ansprechen von EDIABAS oder WinKFP

·Im Mehrkanalbetrieb, wenn das Fahrzeug den Mehrkanalbetrieb nicht unterstützt


Bedienung Konfiguration

Zurück zu:

Bedienung Hauptfenster

Anhand der vorgenommenen Einstellungen werden die Dateien KMM_BACK.DAT und ID_CHECK.DAT neu generiert. Die zur Auswahl angebotenen Optionen werden durch die KMM und die Datei TRAILER.DAT bestimmt.

Die Auswahl der zu flashenden Komponenten erfolgt in der Reihenfolge

- Baureihe

- I-Stufe

- Steuergerät (Mehrfachselektion möglich)

In der Regel wird die mit OK bestätigte Auswahl übernommen und folgende Dateien erzeugt:

- KMM_BACK.DATneu generiert, alte Daten gehen verloren

- ID_CHECK.DATneu generiert, alte Daten gehen verloren

- SGSIM.DATwird ergänzt, Einträge mit Fahrgestellnummer+Baureihe

(anstelle der FG-Nr. wird der IP-Name des Rechners eingetragen)

Bei einigen Steuergeräten ist eine eindeutige Zuordnung nicht möglich. In diesen Fällen wird der Bediener darauf aufmerksam gemacht und muss den Konflikt manuell auflösen.

Siehe auch:

Bedienung Konfiguration (Konflikt)


Bedienung Konfiguration (Konflikt)

Zurück zu:

Bedienung Hauptfenster

Bedienung Konfiguration

Konfigurationsdialog mit nicht eindeutiger Zuordnung (Beispiel)

Bei einigen Steuergeräten ist eine eindeutige Zuordnung nicht möglich. In diesen Fällen wird der Bediener darauf aufmerksam gemacht und muss den Konflikt manuell auflösen.

Die Auswahl der "richtigen" Zuordnung erfordert Spezialkenntnisse. Die Auswahl muss zur Sicherheit im folgenden Dialog (Bestätigung der gewählten ZB-Nummer) bestätigt werden:

Bei weiterhin bestehenden Uneindeutigkeiten versucht das Programm die beste Auswahl zu Treffen. Es werden alle Optionen in die KMM_BACK.DAT eingetragen, bis auf die wahrscheinlichste Option jedoch alle anderen auskommentiert. Der Bediener erhält eine Hinweis auf den Datenkonflikt und dadurch die Möglichkeit die automatisch generierte Datei zu überprüfen und ggf. zu ändern.

Beispiel für eine automatisch generierte KMM_BACK.DAT mit Datenkonflikt:

; ----------------------------------------------------------

; Trailer Konfiguration

; 20.09.2004 14:48

; ----------------------------------------------------------

;

[E89X]

E89X-04-12-431 29 S??? K6769019 Z6769779 ; DSC_DXC:DSC:MK60:E90

E89X-04-12-431 29 S??? K6769882 Z6769779 ; DSC_DXC:DSC:MK60:E90

E89X-04-12-431 29 S??? K6766118 Z6769781 ; DSC_DXC:DSC:E9X:MK60E5 (Plus) (6Z)

E89X-04-12-431 29 S??? K6769840 Z6769781 ; DSC_DXC:DSC:E9X:MK60E5 (Plus) (6Z)

E89X-04-12-431 29 S??? K6769884 Z6769781 ; DSC_DXC:DSC:E9X:MK60E5 (Plus) (6Z)

E89X-04-12-431 29 S??? K6766120 Z6769781 ; DSC_DXC:DSC:E9X:MK60E5 (Plus) (6Z)

E89X-04-12-431 29 S??? K6769842 Z6769781 ; DSC_DXC:DSC:E9X:MK60E5 (Plus) (6Z

E89X-04-12-431 29 S??? K6769886 Z6769781 ; DSC_DXC:DSC:E9X:MK60E5 (Plus) (6Z)

E89X-04-12-431 29 S??? K6769783 Z6769781 ; DSC_DXC:DSC:E9X:MK60E5 (Plus) (6Z)

;E89X-04-12-431 29 S??? K6766118 Z6769783 ; DSC_DXC:DSC:E9X:MK60E5 (Plus) (6Z) : doppelt !!

;E89X-04-12-431 29 S??? K6769840 Z6769783 ; DSC_DXC:DSC:E9X:MK60E5 (Plus) (6Z) : doppelt !!

;E89X-04-12-431 29 S??? K6769884 Z6769783 ; DSC_DXC:DSC:E9X:MK60E5 (Plus) (6Z) : doppelt !!

;E89X-04-12-431 29 S??? K6769781 Z6769783 ; DSC_DXC:DSC:E9X:MK60E5 (Plus) (6Z) : Konflikt !!

;E89X-04-12-431 29 S??? K6766120 Z6769783 ; DSC_DXC:DSC:E9X:MK60E5 (Plus) (6Z) : doppelt !!

;E89X-04-12-431 29 S??? K6769842 Z6769783 ; DSC_DXC:DSC:E9X:MK60E5 (Plus) (6Z) : doppelt !!

;E89X-04-12-431 29 S??? K6769886 Z6769783 ; DSC_DXC:DSC:E9X:MK60E5 (Plus) (6Z) : doppelt !!

E89X-04-12-431 29 S??? K4033011 Z4033013 ; DSC_DXC:DXC8+_E90/E91: xDrive (m. Kupplungsr.)

;EOF


Musterkonfigurationen

Konstellation | Anwendungsfall | Instanzen | Kanäle je Instanz
 | CASCADE (NFS-Light) Normalbetrieb Trailerbetrieb | 1 | 1
 | Normalbetrieb Trailerbetrieb | 2 | 1
 | Normalbetrieb Trailerbetrieb | 2 | 2
Sonderbetriebsarten | CKD-Werk (HO-Modus) Notfallflashen Motorrad Berlin |  |

Durch die vielfältigen Einstellmöglichkeiten in der Konfiguration bestehen sehr viele Kombinationsmöglichkeiten. Jedoch nur wenige Kombinationen von Konfigurationseinstellungen sind als typisch zu bezeichnen. Die wichtigsten Anwendungsfälle sind hier zusammengefasst.

Von NFS werden max. 9 Instanzen mit je max. 9 Kanälen unterstützt. Typischerweise beschränken sich Mehrkanalanwendungen auf 2 Kanäle, wobei der OPPS zur Anwendung kommt. Anwendungsfälle mit nur einem Kanal verwenden in erster Linie die kostengünstigere Variante des OBD. Darüber hinaus ist die Verwendung unterschiedlichster Hardwareinterfaces sowie das Mischen verschiedener Typen möglich, was jedoch nicht den typischen Anwendungsfällen zugerechnet wird und deshalb nicht als Musterkonfiguration vorliegt.


Konfiguration für CASCADE

Die Konfiguration für CASCADE entspricht weitgehend jener für den Normalbetrieb. Da NFS-Light nur die Fahrzeugkonfiguration liest und nicht flasht, ist 1 OBD-Kanal in jedem Fall ausreichend. Die CASCADE-spezifische Parametrierung erfolgt beim Programmaufruf über die Kommandozeile.

; Start NFS.INI

[KONFIGURATION]

Retry = 0

Logo = B; BMW-Werk

Language = Deutsch; in Deutschland

HO_MODUS = nein

MULTIINSTANZ = nein

FIXEDWINDOW = NEIN; kein Bedienerdialog bei NFS-Light

ON_ZBNR_ERROR_USE_IDNR = JA

ON_IDNR_ERROR_USE_ZBNR = JA

ON_KMM_PROBLEM_TRY_TO_FLASH = Ja

FLASH_ZBNR_ALLWAYS = nein

KMM_BACK = Nein

TestModus = Nein

Signalleuchte= Nein

STICHPROBE = Nein

ZB_CHECK = NEIN

AuftragSimulieren = NEIN

TrailerModus = Nein

[BAUREIHENMATRIX]

E66=E65

E67=E65

[TRACE]

ID_Log = JA ; Erzeugt ID.TRC

FA_Log = JA ; Erzeugt FA.TRC

KMM_Log = JA ; Erzeugt KMM.TRC

WARN_Log = JA ; Warnungen in ERROR.TRC

FZG_Log = JA ; Erzeugt FZG.TMP

ZB_Log = JA ; Erzeugt ZB.TMP

[REKONFIGURATION]

DateiNameEin = C:\NFS\BATCH\MESSAGE.MSG

DateiNameAus = C:\NFS\BATCH\MESSAGE.OLD

[ANZEIGE]

Kopfzeile = JA

BatterieZuendung = JA

[E65]

UBatt_SGBD = UTILITY

UBatt_JOB = STATUS_ZUENDUNG

UBatt_RESULT = STAT_ZUENDUNG

UBatt_MIN = 1

UBatt_MAX = 1

[RR1]

UBatt_SGBD = UTILITY

UBatt_JOB = STATUS_ZUENDUNG

UBatt_RESULT = STAT_ZUENDUNG

UBatt_MIN = 1

UBatt_MAX = 1

; Ende NFS.INI


Konfiguration für Normalbetrieb (1/1)

Konfiguration für Normalbetrieb (1 Instanz / 1 Kanal)

Musterkonfiguration für den Normalbetrieb mit 1 Instanz und 1 Kanal (OBD).

; Start NFS.INI

[KONFIGURATION]

Retry = 0

Logo = B; BMW-Werk

Language = Deutsch; in Deutschland

HO_MODUS = nein

MULTIINSTANZ = nein

FIXEDWINDOW = ja

ON_ZBNR_ERROR_USE_IDNR = JA

ON_IDNR_ERROR_USE_ZBNR = JA

ON_KMM_PROBLEM_TRY_TO_FLASH = Ja

FLASH_ZBNR_ALLWAYS = nein

KMM_BACK = Nein

TestModus = Nein

Signalleuchte= Nein

STICHPROBE = Nein

ZB_CHECK = NEIN

AuftragSimulieren = NEIN

TrailerModus = Nein

[BAUREIHENMATRIX]

E66=E65

E67=E65

[TRACE]

ID_Log = JA ; Erzeugt ID.TRC

FA_Log = JA ; Erzeugt FA.TRC

KMM_Log = JA ; Erzeugt KMM.TRC

WARN_Log = JA ; Warnungen in ERROR.TRC

FZG_Log = JA ; Erzeugt FZG.TMP

ZB_Log = JA ; Erzeugt ZB.TMP

[REKONFIGURATION]

DateiNameEin = C:\NFS\BATCH\MESSAGE.MSG

DateiNameAus = C:\NFS\BATCH\MESSAGE.OLD

[ANZEIGE]

Kopfzeile = JA

BatterieZuendung = JA

[E65]

UBatt_SGBD = UTILITY

UBatt_JOB = STATUS_ZUENDUNG

UBatt_RESULT = STAT_ZUENDUNG

UBatt_MIN = 1

UBatt_MAX = 1

[RR1]

UBatt_SGBD = UTILITY

UBatt_JOB = STATUS_ZUENDUNG

UBatt_RESULT = STAT_ZUENDUNG

UBatt_MIN = 1

UBatt_MAX = 1

; Ende NFS.INI


Konfiguration für Normalbetrieb (2/1)

Konfiguration für Normalbetrieb (2 Instanzen / je 1 Kanal)

Musterkonfiguration für den Normalbetrieb mit 2 Instanzen und je 1 Kanal (OBD).

; Start NFS.INI

[KONFIGURATION]

Retry = 0

Logo = B; BMW-Werk

Language = Deutsch; in Deutschland

HO_MODUS = nein

MULTIINSTANZ = JA; mehrere (2) Instanzen

FIXEDWINDOW = ja

ON_ZBNR_ERROR_USE_IDNR = JA

ON_IDNR_ERROR_USE_ZBNR = JA

ON_KMM_PROBLEM_TRY_TO_FLASH = Ja

FLASH_ZBNR_ALLWAYS = nein

KMM_BACK = Nein

TestModus = Nein

Signalleuchte= Nein

STICHPROBE = Nein

ZB_CHECK = NEIN

AuftragSimulieren = NEIN

TrailerModus = Nein

[ INSTANZ_1 ]

Interface=STD:OBD

Unit=A ; --> Verweis auf OBD.INI

MEHRKANAL=nein

[ INSTANZ_2 ]

Interface=STD:OBD

Unit=B ; --> Verweis auf OBD.INI

MEHRKANAL=nein

[BAUREIHENMATRIX]

E66=E65

E67=E65

[TRACE]

ID_Log = JA ; Erzeugt ID.TRC

FA_Log = JA ; Erzeugt FA.TRC

KMM_Log = JA ; Erzeugt KMM.TRC

WARN_Log = JA ; Warnungen in ERROR.TRC

FZG_Log = JA ; Erzeugt FZG.TMP

ZB_Log = JA ; Erzeugt ZB.TMP

[REKONFIGURATION]

DateiNameEin = C:\NFS\BATCH\MESSAGE.MSG

DateiNameAus = C:\NFS\BATCH\MESSAGE.OLD

[ANZEIGE]

Kopfzeile = JA

BatterieZuendung = JA

[E65]

UBatt_SGBD = UTILITY

UBatt_JOB = STATUS_ZUENDUNG

UBatt_RESULT = STAT_ZUENDUNG

UBatt_MIN = 1

UBatt_MAX = 1

[RR1]

UBatt_SGBD = UTILITY

UBatt_JOB = STATUS_ZUENDUNG

UBatt_RESULT = STAT_ZUENDUNG

UBatt_MIN = 1

UBatt_MAX = 1

; Ende NFS.INI


Konfiguration für Normalbetrieb (2/2)

Konfiguration für Normalbetrieb (2 Instanzen / je 2 Kanäle)

Musterkonfiguration für den Normalbetrieb mit 2 Instanzen und je 2 Kanälen (OPPS).

; Start NFS.INI

[KONFIGURATION]

Retry = 0

Logo = B; BMW-Werk

Language = Deutsch; in Deutschland

HO_MODUS = nein

MULTIINSTANZ = JA; mehrere (2) Instanzen

FIXEDWINDOW = ja

ON_ZBNR_ERROR_USE_IDNR = JA

ON_IDNR_ERROR_USE_ZBNR = JA

ON_KMM_PROBLEM_TRY_TO_FLASH = Ja

FLASH_ZBNR_ALLWAYS = nein

KMM_BACK = Nein

TestModus = Nein

Signalleuchte= Nein

STICHPROBE = Nein

ZB_CHECK = NEIN

AuftragSimulieren = NEIN

TrailerModus = Nein

[ INSTANZ_1 ]

Interface=remote:OBD_ab625 ; --> Verweis auf REMOTE.INI

MEHRKANAL=ja

Interface_1= remote:OBD_ab625

Interface_2= remote:MOST_CTRL_ab625

[ INSTANZ_2 ]

Interface=remote:OBD_ab625 ; --> Verweis auf REMOTE.INI

MEHRKANAL=ja

Interface_1= remote:OBD_ab625

Interface_2= remote:MOST_CTRL_ab625

[BAUREIHENMATRIX]

E66=E65

E67=E65

[TRACE]

ID_Log = JA ; Erzeugt ID.TRC

FA_Log = JA ; Erzeugt FA.TRC

KMM_Log = JA ; Erzeugt KMM.TRC

WARN_Log = JA ; Warnungen in ERROR.TRC

FZG_Log = JA ; Erzeugt FZG.TMP

ZB_Log = JA ; Erzeugt ZB.TMP

[REKONFIGURATION]

DateiNameEin = C:\NFS\BATCH\MESSAGE.MSG

DateiNameAus = C:\NFS\BATCH\MESSAGE.OLD

[ANZEIGE]

Kopfzeile = JA

BatterieZuendung = JA

[E65]

UBatt_SGBD = UTILITY

UBatt_JOB = STATUS_ZUENDUNG

UBatt_RESULT = STAT_ZUENDUNG

UBatt_MIN = 1

UBatt_MAX = 1

[RR1]

UBatt_SGBD = UTILITY

UBatt_JOB = STATUS_ZUENDUNG

UBatt_RESULT = STAT_ZUENDUNG

UBatt_MIN = 1

UBatt_MAX = 1

; Ende NFS.INI


Konfiguration für Trailerbetrieb (1/1)

Konfiguration für Trailerbetrieb (1 Instanz / 1 Kanal)

Musterkonfiguration für den Trailerbetrieb mit 1 Instanz und 1 Kanal (OBD).

; Start NFS.INI

[KONFIGURATION]

Retry = 0

Logo = B; BMW-Werk

Language = Deutsch; in Deutschland

HO_MODUS = nein

MULTIINSTANZ = nein

FIXEDWINDOW = ja

ON_ZBNR_ERROR_USE_IDNR = JA

ON_IDNR_ERROR_USE_ZBNR = JA

ON_KMM_PROBLEM_TRY_TO_FLASH = Ja

FLASH_ZBNR_ALLWAYS = nein

KMM_BACK = Nein

TestModus = Nein

Signalleuchte = JA; Signalleuchte vorhanden

STICHPROBE = Nein

ZB_CHECK = NEIN

AuftragSimulieren = NEIN

TrailerModus = Ja

[BAUREIHENMATRIX]

E66=E65

E67=E65

[TRACE]

ID_Log = JA ; Erzeugt ID.TRC

FA_Log = JA ; Erzeugt FA.TRC

KMM_Log = JA ; Erzeugt KMM.TRC

WARN_Log = JA ; Warnungen in ERROR.TRC

FZG_Log = JA ; Erzeugt FZG.TMP

ZB_Log = JA ; Erzeugt ZB.TMP

[REKONFIGURATION]

DateiNameEin = C:\NFS\BATCH\MESSAGE.MSG

DateiNameAus = C:\NFS\BATCH\MESSAGE.OLD

[ANZEIGE]

Kopfzeile = JA

BatterieZuendung = JA

[E65]

UBatt_SGBD = UTILITY

UBatt_JOB = STATUS_ZUENDUNG

UBatt_RESULT = STAT_ZUENDUNG

UBatt_MIN = 1

UBatt_MAX = 1

[RR1]

UBatt_SGBD = UTILITY

UBatt_JOB = STATUS_ZUENDUNG

UBatt_RESULT = STAT_ZUENDUNG

UBatt_MIN = 1

UBatt_MAX = 1

[TRAILERPROFIL]

Text_1 = 1 OBD

Datei_1 = C:\NFS\bin\nfs.1

Text_2 = 3 Funk

Datei_2 = C:\NFS\bin\nfs.2

Text_3 = 3 OBD

Datei_3 = C:\NFS\bin\nfs.3

; Ende NFS.INI


Konfiguration für Trailerbetrieb (2/1)

Konfiguration für Trailerbetrieb (2 Instanzen / je 1 Kanal)

Musterkonfiguration für den Trailerbetrieb mit 2 Instanzen und je 1 Kanal (OBD).

; Start NFS.INI

[KONFIGURATION]

Retry = 0

Logo = B; BMW-Werk

Language = Deutsch; in Deutschland

HO_MODUS = nein

MULTIINSTANZ = JA; mehrere (2) Instanzen

FIXEDWINDOW = ja

ON_ZBNR_ERROR_USE_IDNR = JA

ON_IDNR_ERROR_USE_ZBNR = JA

ON_KMM_PROBLEM_TRY_TO_FLASH = Ja

FLASH_ZBNR_ALLWAYS = nein

KMM_BACK = Nein

TestModus = Nein

Signalleuchte = JA; Signalleuchte vorhanden

STICHPROBE = Nein

ZB_CHECK = NEIN

AuftragSimulieren = NEIN

TrailerModus = JA

[ INSTANZ_1 ]

Interface=STD:OBD

Unit=A ; --> Verweis auf OBD.INI

MEHRKANAL=nein

[ INSTANZ_2 ]

Interface=STD:OBD

Unit=B ; --> Verweis auf OBD.INI

MEHRKANAL=nein

[BAUREIHENMATRIX]

E66=E65

E67=E65

[TRACE]

ID_Log = JA ; Erzeugt ID.TRC

FA_Log = JA ; Erzeugt FA.TRC

KMM_Log = JA ; Erzeugt KMM.TRC

WARN_Log = JA ; Warnungen in ERROR.TRC

FZG_Log = JA ; Erzeugt FZG.TMP

ZB_Log = JA ; Erzeugt ZB.TMP

[REKONFIGURATION]

DateiNameEin = C:\NFS\BATCH\MESSAGE.MSG

DateiNameAus = C:\NFS\BATCH\MESSAGE.OLD

[ANZEIGE]

Kopfzeile = JA

BatterieZuendung = JA

[E65]

UBatt_SGBD = UTILITY

UBatt_JOB = STATUS_ZUENDUNG

UBatt_RESULT = STAT_ZUENDUNG

UBatt_MIN = 1

UBatt_MAX = 1

[RR1]

UBatt_SGBD = UTILITY

UBatt_JOB = STATUS_ZUENDUNG

UBatt_RESULT = STAT_ZUENDUNG

UBatt_MIN = 1

UBatt_MAX = 1

[TRAILERPROFIL]

Text_1 = 1 OBD

Datei_1 = C:\NFS\bin\nfs.1

Text_2 = 3 Funk

Datei_2 = C:\NFS\bin\nfs.2

Text_3 = 3 OBD

Datei_3 = C:\NFS\bin\nfs.3

; Ende NFS.INI


Konfiguration für Trailerbetrieb (2/2)

Konfiguration für Trailerbetrieb (2 Instanzen / je 2 Kanäle)

Musterkonfiguration für den Trailerbetrieb mit 2 Instanzen und je 2 Kanälen (OPPS).

; Start NFS.INI

[KONFIGURATION]

Retry = 0

Logo = B; BMW-Werk

Language = Deutsch; in Deutschland

HO_MODUS = nein

MULTIINSTANZ = JA; mehrere (2) Instanzen

FIXEDWINDOW = ja

ON_ZBNR_ERROR_USE_IDNR = JA

ON_IDNR_ERROR_USE_ZBNR = JA

ON_KMM_PROBLEM_TRY_TO_FLASH = Ja

FLASH_ZBNR_ALLWAYS = nein

KMM_BACK = Nein

TestModus = Nein

Signalleuchte = JA; Signalleuchte vorhanden

STICHPROBE = Nein

ZB_CHECK = NEIN

AuftragSimulieren = NEIN

TrailerModus = JA

[ INSTANZ_1 ]

Interface=remote:OBD_ab625 ; --> Verweis auf REMOTE.INI

MEHRKANAL=ja

Interface_1= remote:OBD_ab625

Interface_2= remote:MOST_CTRL_ab625

[ INSTANZ_2 ]

Interface=remote:OBD_ab625 ; --> Verweis auf REMOTE.INI

MEHRKANAL=ja

Interface_1= remote:OBD_ab625

Interface_2= remote:MOST_CTRL_ab625

[BAUREIHENMATRIX]

E66=E65

E67=E65

[TRACE]

ID_Log = JA ; Erzeugt ID.TRC

FA_Log = JA ; Erzeugt FA.TRC

KMM_Log = JA ; Erzeugt KMM.TRC

WARN_Log = JA ; Warnungen in ERROR.TRC

FZG_Log = JA ; Erzeugt FZG.TMP

ZB_Log = JA ; Erzeugt ZB.TMP

[REKONFIGURATION]

DateiNameEin = C:\NFS\BATCH\MESSAGE.MSG

DateiNameAus = C:\NFS\BATCH\MESSAGE.OLD

[ANZEIGE]

Kopfzeile = JA

BatterieZuendung = JA

[E65]

UBatt_SGBD = UTILITY

UBatt_JOB = STATUS_ZUENDUNG

UBatt_RESULT = STAT_ZUENDUNG

UBatt_MIN = 1

UBatt_MAX = 1

[RR1]

UBatt_SGBD = UTILITY

UBatt_JOB = STATUS_ZUENDUNG

UBatt_RESULT = STAT_ZUENDUNG

UBatt_MIN = 1

UBatt_MAX = 1

[TRAILERPROFIL]

Text_1 = 1 OBD

Datei_1 = C:\NFS\bin\nfs.1

Text_2 = 3 Funk

Datei_2 = C:\NFS\bin\nfs.2

Text_3 = 3 OBD

Datei_3 = C:\NFS\bin\nfs.3

; Ende NFS.INI


Konfiguration für CKD-Werk (HO-Modus)

In CKD-Werken und im Bereich nach F2 kommt der HO-Modus zum Einsatz. In diesem Modus wird zwar die Kompatibilität der Steuergeräte untereinander überprüft und sichergestellt, es erfolgt jedoch nicht zwingend ein Update auf die aktuellste Integrationsstufe.

Hinsichtlich der Konfiguration können die Einstellungen des Normalbetriebs verwendet werden, die in folgendem Punkt in der NFS.INI abgeändert werden müssen:

[KONFIGURATION]

HO_MODUS = JA


Konfiguration für Notfallflashen

Das Notfallflashen kommt immer dann zum Einsatz, wenn die Kombination aus Auftragsdaten und Identdaten nicht vorliegt bzw. nicht ermittelt werden kann.

Praxisbeispiele:

·Das Fahrzeug verfügt über kein CAS (Car Access System), es müssen jedoch einzelne Steuergeräte geflasht werden.

·Teile eines Fahrzeugs sind "unsichtbar", weil ein Steuergerät mit Gatewayfunktion nicht funktioniert (z.B. Programmierabbruch). Mittels Notfallflashen wird die Funktionsfähigkeit des Gateways wiederhergestellt, anschließend wird mit dem Normalablauf fortgefahren.

Für das Notfallflashen müssen die erforderlichen Angaben für die zu flashenden Steuergeräte in der Datei NOTFALL.DAT eingetragen werden.

Beispiel für den Aufbau der NOTFALL.DAT:

; Start NOTFALL.DAT

;

; Liste der für Notfallflashen erlaubten Zusbau-Nummern

;

; Datenformat einer Zeile:

;

; 1. Integrationsstufe XX.XXXX

; alphanumerisch 4 bis 7-stellig Wildcard ? erlaubt

; Wird ignoriert, muss aber syntaktisch korrekt sein. Es sollte ??.???? benutzt werden

;

; 2. SG-Adresse 2-stellig hex

;

; 3. Typschlüssel T + 4-stellig alphanumerisch, Wildcard ? erlaubt, Negation ! erlaubt

; Wird ignoriert, muss aber syntaktisch korrekt sein. Es sollte T???? benutzt werden

;

; 4. Sonderausstattung S + 3-stellig numerisch Wildcard ? erlaubt Negation ! erlaubt

; Wird ignoriert, muss aber syntaktisch korrekt sein. Sollte nicht benutzt werden

;

; 5. Zusbau-Nummer Z + 7-stellig numerisch

;

;

[MUSTER]

??.???? 0F T???? Z6918086

??.???? 02 T???? Z6918623

; Zusbau-Nummer 1234567 mit SG-Adresse 0F und

; Zusbau-Nummer 7654321 mit SG-Adresse 02 kann Notfall programmiert werden

[E65]

[E60]

[RR1]

; Ende NOTFALL.DAT


Konfiguration für Motorrad Berlin

Für den Einsatz im Motorradwerk in Berlin kann anstelle der SGBD "CAS" eine alternative SGBD für den Bezug der Auftragdaten verwendet werden.

Beispiel für den Inhalt der NFS.INI (Auszug):

[BAUREIHENMATRIX]

Auftrag_SGBD = MRK24


Konfiguration Multiinstanz + Mehrkanal

Nur eine Instanz

Im Singleinstanz-Betrieb ist der Abschnitt [INSTANZ] nur dann erforderlich, wenn entweder

·NFS einen anderen als in EDIABAS voreingestellten Kanal verwenden soll oder

·NFS im Multikanal-Modus betrieben werden soll

Durch das Weglassen des Abschnitts wird sichergestellt, dass eine Umstellung des Kanals in EDIABAS automatisch ohne Anpassung der NFS.INI auch für NFS wirksam wird.

Ein bekanntes Anwendungsbeispiel für unterschiedliche Kanäle ist die Kommunikation über Funk-Adapter. NFS liest mittels EDIABAS die Fahrzeugkonfiguration über Funk aus, das Fahrzeug muss dazu nicht angesteckt werden. Wird jedoch festgestellt, dass ein Steuergerät geflasht werden muss, erfolgt dies über einen anderen Kanal (Fahrzeug wird angesteckt) mit höherer Übertragungsrate und höherer Übertragungssicherheit.

Beispiel:

[INSTANZ]

Interface=STD:OBD --> Verweis auf OBD.INI

Unit=A

MEHRKANAL=nein

Mehrere Instanzen

Im Multiinstanzbetrieb hingegen ist der Abschnitt für jede Instanz zwingend erforderlich ([INSTANZ_1], [INSTANZ_2] usw.).

Beispiel 2 Instanzen mit OBD

[INSTANZ_1]

Interface=STD:OBD --> Verweis auf OBD.INI

Unit=A

MEHRKANAL=nein

[INSTANZ_2]

Interface=STD:OBD

Unit=B

MEHRKANAL=nein

Mehrkanalbetrieb

Im Mehrkanalbetrieb müssen die Abschnitte [INHALT] bzw. [INHALT_x] um 2 Einträge je Kanal erweitert werden. Die Einträge Interface und Unit beschreiben den von NFS (über EDIABAS) benutzten Kanal, die Einträge Interface_x und Unit_x beschreiben die von WinKFP benutzten Kanäle. Da die Benutzung von NFS und WinKFP nie gleichzeitig erfolgt, kann NFS durchaus den selben Kanal wie eine der WinKFP-Instanzen benutzen.

Beispiel für 2 Instanzen mit je 2 Kanälen:

[INSTANZ_1]

Interface=remote:OBD_ab625 --> Verweis auf REMOTE.INI

MEHRKANAL=ja

Interface_1= remote:OBD_ab625

Interface_2= remote:MOST_CTRL_ab625

[INSTANZ_2]

Interface=remote:OBD_ab625

MEHRKANAL=ja

Interface_1= remote:OBD_ab625

Interface_2= remote:MOST_CTRL_ab625


Konfiguration OBD.INI

Diese Musterkonfiguration zeigt die OBD.INI auf die in den Beispielen für NFS.INI Bezug genommen wird. Damit soll nur der Zusammenhang zwischen den Einträgen in NFS.INI und OBD.INI verdeutlicht werden. Im Einzelfall muss die OBD.INI auf die vorhandenen Gegebenheiten (Hardwarekonfiguration etc.) angepasst werden.

Weiterführende Informationen zur Konfiguration siehe EDIABAS-Dokumentation.

; Start OBD.INI

[OBD]

Port=Com1

Hardware=OBD

RETRY=OFF

Tracelevel =0

;Tracelevel=0xFFFFFFFF

;Tracelevel=0x0FFF0000

;Tracelevel=0xFFFFFFFF

;Tracelevel=0xF0000000

;Tracelevel=0x0000FFFF

; Bit 0 = Funktionsaufruf

; Bit 1 = io Ergebnis

; Bit 2 = nio Ergebnis

; Bit 3 = Detailinfos

; Nibble 0 = readchar_wait

; Nibble 1 = main

; Nibble 2 = cmd

; Nibble 3 = obd

; Nibble 4 = send_and_receive_...

; Nibble 5 = read_telegram_...

; Nibble 6 = send_telegram

; Nibble 7 = SendData

[UNIT_1]

Port=Com1

MODE=KBUS

Tracelevel=0x0FFF00FF

[UNIT_2]

Port=Com2

MODE=KBUS

[UNIT_A]

Port=Com1

[UNIT_B]

Port=Com2

[UNIT_C]

Port=Com3

[UNIT_D]

Port=Com4

; Ende OBD.INI


Konfiguration REMOTE.INI

Diese Musterkonfiguration zeigt die REMOTE.INI auf die in den Beispielen für NFS.INI Bezug genommen wird. Damit soll nur der Zusammenhang zwischen den Einträgen in NFS.INI und REMOTE.INI verdeutlicht werden. Im Einzelfall muss die REMOTE.INI auf die vorhandenen Gegebenheiten (Hardwarekonfiguration etc.) angepasst werden.

Unbedingt zu beachten ist, dass sich für OPPS ab Firmware V6.25 die Konfiguration unterscheidet.

Weiterführende Informationen zur Konfiguration siehe EDIABAS-Dokumentation.

;#### Remote.ini Musterdatei für OPPS Firmware Version ab 625 ####

; Ab Firmware Version 625 ist das OBD Interface fest auf Port 6801
; und das MOST Interface

; fest auf Port 6802. Parallelbetrieb sofort erlaubt.

; Router Kommandos sind ab dieser Version verboten. (Init CMDs mit FE am Anfang)

[OBD_ab625]

ek_info = OPPS Betrieb mit OBD Interface, also K-Line oder D-CAN

RemoteHost=opps_name

;Dieser Port hat _immer_ das OBD Interface, also K-Line oder D-CAN

port = 6801

[MOST_CTRL_ab625]

ek_info = OPPS Betrieb mit MOST Interface, Asynchronkanal gesperrt

RemoteHost = opps_name

; Dieser Port hat _immer_ das MOST Interface

port = 6802

; Asynchronkanal sperren

InitCmd0= FD 05 00 03 00

[MOST_ASYNC_ab625]

ek_info = OPPS Betrieb mit MOST Interface, Asynchronkanal erlaubt

RemoteHost = opps_name

; Dieser Port hat _immer_ das MOST Interface

port =6802

; Asynchronkanal erlauben

InitCmd0= FD 05 00 03 01

; ab 0 Bytes Asynchronkanal benutzen

InitCmd1= FD 06 00 97 00 00

; Bei Steuergeräten, die den Asynchronkanal nicht unterstützen,

; und bei Telegrammen Mit SID != 0x36 wird automatisch der Kontrollkanal verwendet

[MOST_MASTER_ab625]

ek_info = OPPS Most-Master und Clock-Master

RemoteHost=opps_name

port =6802

InitCmd0 = FD 06 00 01 01 01

DisconnectOnApiEnd = 1

;#### Remote.ini Musterdatei für OPPS Firmware Version kleiner 625 ####

[Base]

ek_info = Einfacher Betrieb im Automatik - Router Modus

RemoteHost=opps_name

port = 6801

InitCmd0 = FE 04 00 85

DisconnectOnApiEnd = 1

[DiagBus]

ek_info = Mehrfachbetrieb: Nutzt nur K-Line, gibt MOST frei

RemoteHost=opps_name

port = 6801

InitCmd0 = FE 05 00 80 05

DisconnectOnApiEnd = 1

[MOST]

ek_info = Mehrfachbetrieb: Nutzt MOST, gibt K-Line frei

RemoteHost=opps_name

port = 6802

InitCmd0 = FE 05 00 80 01

DisconnectOnApiEnd = 1

[MOST_CTRL]

ek_info = Mehrfachbetrieb: Nutzt MOST, Asynchronkanal gesperrt, gibt K-Line frei

RemoteHost=opps_name

port =6802

InitCmd0 = FE 05 00 80 01

;Asynchron ausschalten

InitCmd1 = FD 05 00 03 00

DisconnectOnApiEnd = 1

[MOST_ASYNC]

ek_info = Mehrfachbetrieb: Nutzt MOST mit Asynchronkanal, gibt K-Line frei

RemoteHost=opps_name

port =6802

InitCmd0 = FE 05 00 80 01

;Asynchron einschalten

InitCmd1 = FD 05 00 03 01

;Ab 190 Bytes Telegrammlängen Asynchronkanal benutzen

InitCmd2 = FD 06 00 97 BE 00

DisconnectOnApiEnd = 1

[AUTO_ASYNC]

ek_info = Einfachbetrieb mit automatischer Umschaltung K-Line / MOST, Kontroll / Asynchronkanal

RemoteHost=opps_name

port = 6802

; Router auf MOST

InitCmd0 = FE 04 00 01

;Asynchron einschalten

InitCmd1 = FD 05 00 03 01

;Ab 190 Bytes Telegrammlängen Asynchronkanal benutzen

InitCmd2 = FD 06 00 97 BE 00

; Router wieder auf Automatik

InitCmd3 = FE 04 00 00

DisconnectOnApiEnd = 1

[MOST_MASTER]

ek_info = OPPS Most-Master und Clock-Master

RemoteHost=opps_name

port = 6802

InitCmd0 = FE 04 00 01

InitCmd1 = FD 06 00 01 01 01

DisconnectOnApiEnd = 1


Referenz NFS.INI

[Konfiguration]

Retry
Logo
Language
ON_ZBNR_ERROR_USE_IDNR
ON_IDNR_ERROR_USE_ZBNR
ON_KMM_PROBLEM_TRY_TO_FLASH
FLASH_ZBNR_ALLWAYS
KMM_BACK
TestModus
STICHPROBE
ZB_CHECK
AuftragSimulieren
MULTIINSTANZ
FIXEDWINDOW
HO_MODUS
TRAILERMODUS
SIGNALLEUCHTE

[INSTANZ]

Interface
Unit
Mehrkanal

[TRACE]

ID_Log
FA_Log
KMM_Log
WARN_Log
FZG_Log
ZB_Log

[REKONFIGURATION]

DateiNameEin
DateiNameAus

[ANZEIGE]

Kopfzeile
BatterieZuendung
WinPos…

[BAUREIHENMATRIX]

Eyy = Exx
Ezz = Exx
Auftrag_SGBD

[Exx]

UBatt_SGBD
UBatt_JOB
UBatt_RESULT
UBatt_MIN
UBatt_MAX

[Trailerprofil]

Text_x
Datei_x


Referenz ANLAGE.INI

[KONFIGURATION]

Anlage


Referenz Kommandozeile

In der beim Programmstart übergebenen Kommandozeile erhält das Programm NFS Informationen zur Steuerung des Ablaufs.

Folgende Angaben in der Kommandozeile werden im Rahmen der Anwendung CASCADE verwendet:

ZB_CHECK | Cascade-Aufruf, nur Überprüfung der Fahrzeugdaten (ZB-Nummern)
APP_ZB_CHECK | Cascade-Aufruf, nur Überprüfung der Fahrzeugdaten (ZB-Nummern), ignoriert fehlende SG (Fahrzeug noch nicht komplett aufgebaut)
AUTOMATIC_FLASH | Flash Automatik-Mode (ohne Bedienereingaben)
APP_AUTOMATIC_FLASH | Flash Automatik-Mode (ohne Bedienereingaben)
-XML<datei> | Vollständiger Pfad auf die Cascade XML-Datei
-DTD<datei> | Vollständiger Pfad auf die Cascade DTD-Datei
-FGNR<fgnr> | Fahrgestellnummer des aktuellen Fahrzeugs

Anmerkung: Es kann immer nur eine der Optionen ZB_CHECK, APP_ZB_CHECK, AUTOMATIC_FLASH bzw. APP_AUTOMATIC_FLASH eingestellt werden.

Folgende Voreinstellungen werden verwendet wenn der entsprechende Parameter nicht in der Kommandozeile enthalten ist (Pfade relativ zur ausgeführten Datei) :

-XML | ..\TRACE\CASCADE.XML
-DTD | ..\TRACE\CASCADE.DTD
-FGNR | <leer>

Ein Beispiel für eine gültige Kommandozeile wäre:

NFS.EXE ZB_CHECK -XMLC:\xxx\yyy\zzz.XML -DTD"C:\aaa\bbb\ccc ddd.XML" -FGNRWBA12345678901234

Hinweis: Wenn der Dateiname <datei> Leerzeichen enthält, muss dieser wie im obigen -DTD Beispiel mit Hochkomma als "<datei>" angegeben werden.

Anmerkung: In den Pfadangaben darf anstelle des Zeichens "\" auch "/" stehen (wird intern umgewandelt), was hilfreich ist, wenn der Aufruf aus einem Java-Programm heraus erfolgt.


Muster ID_CHECK.DAT

Kopf der Konfigurationsdatei ID_CHECK.DAT, der den Aufbau der Einträge erklärt.

; ID_CHECK.DAT
;
; Liste der zwingend verbauten Steuergeräteadressen und
; der Steuergeräteadressen bei denen der AIF-Eintrag systematisch fehlerhaft ist
;
; Datenformat einer Zeile:
;
; 1. Integrationsstufe EXXX-XX-XX-XXX
; alphanumerisch 14-stellig Wildcard ? erlaubt
;
; Integrationsstufe XX.XXXX ( altes Format )
; alphanumerisch 4 bis 7-stellig Wildcard ? erlaubt
;
; 2. SG-Adresse 2-stellig hex
;
; 3. Typschlüssel T + 4-stellig alphanumerisch Wildcard ? erlaubt Negation ! erlaubt
; Mehrere Typschlüssel werden und-verknüpft
;
; 4. Sonderausstattung S + 3-stellig numerisch Wildcard ? erlaubt Negation ! erlaubt
; Mehrere Sonderausstattungen werden und-verknüpft
;
; 5. Existiert E
; Steuergerät ist zwingend verbaut
;
; 6. AifEingriff A
; Steuergerät hat einen systematisch falschen AIF-Eintrag
;
;
;

[MUSTER]
????-??-??-??? 0F TAB?? T!AB44 S2?? S!201 S400 Existiert AifEingriff

????-??-??-??? 02 T????
; SG-Adresse 02 ist bei beliebiger Integrationsstufe ( immer )
; und beliebigem Typschlüssel ( immer ) verbaut
;

[E65]

[E60]

[RR1]

[E89X]

; EOF


Muster AKTION.DAT

Kopf der Konfigurationsdatei AKTION.DAT, der den Aufbau der Einträge erklärt.

; AKTION.DAT
;
; Liste der zu programmierenden Steuergeräte
;
; Datenformat einer Zeile:
;
; 1. Integrationsstufe EXXX-XX-XX-XXX
; alphanumerisch 14-stellig Wildcard ? erlaubt
;
; Integrationsstufe XX.XXXX ( altes Format )
; alphanumerisch 4 bis 7-stellig Wildcard ? erlaubt
;
; 2. SG-Adresse 2-stellig hex
;
; 3. Typschlüssel T + 4-stellig alphanumerisch Wildcard ? erlaubt Negation ! erlaubt
; Mehrere Typschlüssel werden und-verknüpft
;
; 4. Sonderausstattung S + 3-stellig numerisch Wildcard ? erlaubt Negation ! erlaubt
; Mehrere Sonderausstattungen werden und-verknüpft
;
; 5. Zusbau-Nummer Z + 7-stellig numerisch
;
;
;
;
;
;
;

[MUSTER]
????-??-??-??? 0F TAB?? T!AB44 S2?? S!201 S400 Z1234567

????-??-??-??? 02 T???? Z7654321
; Zusbau-Nummer 7654321 mit SG-Adresse 02 ist bei beliebiger Integrationsstufe ( immer )
; und beliebigem Typschlüssel ( immer ) programmiert
;

[E65]

[E60]

[RR1]

[E89X]

; EOF


Muster NOFLASH.DAT

Kopf der Konfigurationsdatei NOFLASH.DAT, der den Aufbau der Einträge erklärt.

; NOFLASH.DAT
;
; Liste der zu tauschenden Steuergeräte
;
; Datenformat einer Zeile:
;
; 1. Integrationsstufe EXXX-XX-XX-XXX
; alphanumerisch 14-stellig Wildcard ? erlaubt
;
; Integrationsstufe XX.XXXX ( altes Format )
; alphanumerisch 4 bis 7-stellig Wildcard ? erlaubt
;
; 2. SG-Adresse 2-stellig hex
;
; 3. Typschlüssel T + 4-stellig alphanumerisch Wildcard ? erlaubt Negation ! erlaubt
; Mehrere Typschlüssel werden und-verknüpft
;
; 4. Sonderausstattung S + 3-stellig numerisch Wildcard ? erlaubt Negation ! erlaubt
; Mehrere Sonderausstattungen werden und-verknüpft
;
; 5. Zusbau-Nummer Z + 7-stellig numerisch Wildcard ? erlaubt
;
;
;
;
;
;
;

[MUSTER]
????-??-??-??? 0F TAB?? T!AB44 S2?? S!201 S400 Z123456?

????-??-??-??? 02 T???? Z7654321
; Zusbau-Nummer 7654321 mit SG-Adresse 02 ist bei beliebiger Integrationsstufe ( immer )
; und beliebigem Typschlüssel ( immer ) nicht programmiert sondern getauscht
;

[E65]

[E60]

[RR1]

[E89X]

; EOF


Muster SEQUENZ.DAT

Kopf der Konfigurationsdatei SEQUENZ.DAT, der den Aufbau der Einträge erklärt.

; SEQUENZ.DAT
;
; Liste der Flashbedingungen und Programmierreihenfolgen für Ein- und Mehrkanalbetrieb
;
; Datenformat einer Zeile:
;
; 1. Integrationsstufe EXXX-XX-XX-XXX
; alphanumerisch 14-stellig Wildcard ? erlaubt
;
; Integrationsstufe XX.XXXX ( altes Format )
; alphanumerisch 4 bis 7-stellig Wildcard ? erlaubt
;
; 2. SG-Adresse 2-stellig hex
;
; 3. Typschlüssel T + 4-stellig alphanumerisch Wildcard ? erlaubt Negation ! erlaubt
;
; 4. Sonderausstattung S + 3-stellig numerisch Wildcard ? erlaubt Negation ! erlaubt
;
; 5. Bedingung BKL_0 oder BKlemme_0 bzw. BKL_R oder BKlemme_R bzw. BKL_15 oder BKlemme_15
; Defaultwert ist BKL_15, also Programmieren bei Klemme 15 ( Zündung ein )
;
; 6. Kanal K + 1-stellig numerisch Programmierkanal
; Defaultwert ist 1
;
; 7. Zeile Z + 2-stellig numerisch Reihenfolge der Programmierung
; Defaultwert ist 50
;
; 8. Rang R + 2-stellig numerisch Reihenfolge der Programmierung innnerhalb einer Zeile
; Defaultwert ist 50
;
; 9. Wartezeit W + 2-stellig numerisch Wartezeit nach der Programmierung
; Defaultwert ist 00
;
;
[MUSTER]
????-??-??-??? 0F T???? R01

????-??-??-??? 02 T???? BKlemme_R R01 W05
; SG-Adresse 0F wird bei Klemme 15 programmiert mit Rang 1, also als erstes SG
; SG-Adresse 02 wird bei Klemme R programmiert mit Rang 1 und einer Wartezeit von 5 sek
;

[E65]

[E60]

[RR1]

[E89X]

; EOF


Muster SGSIM.DAT

Kopf der Konfigurationsdatei SGSIM.DAT, der den Aufbau der Einträge erklärt.

; SGSIM.DAT
;
; Liste der zu simulierenden Steuergeräte
;
; Datenformat einer Zeile:
;
; 1. Integrationsstufe EXXX-XX-XX-XXX
; alphanumerisch 14-stellig Wildcard ? erlaubt
;
; Integrationsstufe XX.XXXX ( altes Format )
; alphanumerisch 4 bis 7-stellig Wildcard ? erlaubt
;
; 2. SG-Adresse 2-stellig hex
;
; 3. Typschlüssel T + 4-stellig alphanumerisch Wildcard ? erlaubt Negation ! erlaubt
; Mehrere Typschlüssel werden und-verknüpft
;
; 4. Sonderausstattung S + 3-stellig numerisch Wildcard ? erlaubt Negation ! erlaubt
; Mehrere Sonderausstattungen werden und-verknüpft
;
; 5. Zusbau-Nummer Z + 7-stellig numerisch
;
; 6. HW*-Nummer H + 7-stellig numerisch
;
;
;
;
;

; Es kann auch der CAS-Auftrag simuliert werden.
; Er muss in der Sektion [AUFTRAG] stehen und hat die gleiche Form wie die der Trace-Datei FZG.TMP
[MUSTER_AUFTRAG]
FGNR : WBAGM21010DR49348
Baureihe : E65
Mehrkanal : nein
TypSchluessel : GM21
Codierbaustand : 0103
Ist I-Stufe : 6.98
Soll I-Stufe : 6.98
Lack : 0892
Polster : U6FA
SA_Anz : 25
SA202 SA216 SA229 SA238 SA245 SA261 SA302 SA316 SA323 SA438
SA441 SA488 SA502 SA508 SA521 SA522 SA548 SA609 SA630 SA650
SA672 SA676 SA856 SA863 SA883
E_Wort_Anz : 1
LEDE
HO_Wort_Anz : 0

[MUSTER_E65]
????-??-??-??? 0F TAB?? T!AB44 S2?? S!201 S400 Z1234567

????-??-??-??? 02 T???? Z7654321
; Zusbau-Nummer 7654321 mit SG-Adresse 02 ist bei beliebiger Integrationsstufe ( immer )
; und beliebigem Typschlüssel ( immer ) simuliert
;

[E65]

[E60]

[RR1]

[E89X]

; EOF


Muster KMM_BACK.DAT

Kopf der Konfigurationsdatei KMM_BACK.DAT, der den Aufbau der Einträge erklärt.

; KMM_BACK.DAT
;
; Liste der Inkompatibilitäten
;
; Datenformat einer Zeile:
;
; 1. Integrationsstufe EXXX-XX-XX-XXX
; alphanumerisch 14-stellig Wildcard ? erlaubt
;
; Integrationsstufe XX.XXXX ( altes Format )
; alphanumerisch 4 bis 7-stellig Wildcard ? erlaubt
;
; 2. SG-Adresse 2-stellig hex
;
; 3. Typschlüssel T + 4-stellig alphanumerisch Wildcard ? erlaubt Negation ! erlaubt
; Mehrere Typschlüssel werden und-verknüpft
;
; 4. Sonderausstattung S + 3-stellig numerisch Wildcard ? erlaubt Negation ! erlaubt
; Mehrere Sonderausstattungen werden und-verknüpft
;
; 5. Zusbau-Nummer Z + 7-stellig numerisch
;
; 6. Kompatibilitäts-Zusbau-Nummer K + 7-stellig numerisch
; Mehrere Kompatibilitäts-Zusbau-Nummern werden und-verknüpft
;
;
;
;

[MUSTER]
????-??-??-??? 0F TAB?? T!AB44 S2?? S!201 S400 K1234567 K1234568 Z7654321

????-??-??-??? 02 T???? K1111111 Z7654321
; Zusbau-Nummer 7654321 mit SG-Adresse 02 ist bei beliebiger Integrationsstufe ( immer )
; und beliebigem Typschlüssel ( immer ) programmiert, wenn im Fahrzeug die
; Zusbau-Nummer 1111111 verbaut ist

[E65]

[E60]

[RR1]

[E89X]

; EOF


Muster NOTFALL.DAT

Kopf der Konfigurationsdatei NOTFALL.DAT, der den Aufbau der Einträge erklärt.

; NOTFALL.DAT
;
; Liste der für Notfallflashen erlaubten Zusbau-Nummern
;
; Datenformat einer Zeile:
;
; 1. Integrationsstufe EXXX-XX-XX-XXX
; alphanumerisch 14-stellig Wildcard ? erlaubt
;
; Integrationsstufe XX.XXXX ( altes Format )
; alphanumerisch 4 bis 7-stellig Wildcard ? erlaubt
; Wird ignoriert, muss aber syntaktisch korrekt sein. Es sollte ????-??-??-??? benutzt werden
;
; 2. SG-Adresse 2-stellig hex
;
; 3. Typschlüssel T + 4-stellig alphanumerisch Wildcard ? erlaubt Negation ! erlaubt
; Wird ignoriert, muss aber syntaktisch korrekt sein. Es sollte T???? benutzt werden
;
; 4. Sonderausstattung S + 3-stellig numerisch Wildcard ? erlaubt Negation ! erlaubt
; Wird ignoriert, muss aber syntaktisch korrekt sein. Sollte nicht benutzt werden
;
; 5. Zusbau-Nummer Z + 7-stellig numerisch
;
;
;
;
;
;
;

[MUSTER]
????-??-??-??? 0F T???? Z6918086

????-??-??-??? 02 T???? Z6918623
; Zusbau-Nummer 1234567 mit SG-Adresse 0F und
; Zusbau-Nummer 7654321 mit SG-Adresse 02 kann Notfall programmiert werden
;

[E65]

[E60]

[RR1]

[E89X]

; EOF


Muster ZB_CHECK.DAT

Kopf der Konfigurationsdatei ZB_CHECK.DAT, der den Aufbau der Einträge erklärt.

; ZB_CHECK.DAT
;
; Liste der zu prüfenden ZusBau-Nummern der Steuergeräte
;
; Datenformat einer Zeile:
;
; 1. Integrationsstufe EXXX-XX-XX-XXX
; alphanumerisch 14-stellig Wildcard ? erlaubt
;
; Integrationsstufe XX.XXXX ( altes Format )
; alphanumerisch 4 bis 7-stellig Wildcard ? erlaubt
;
; 2. SG-Adresse 2-stellig hex
;
; 3. Typschlüssel T + 4-stellig alphanumerisch Wildcard ? erlaubt Negation ! erlaubt
; Mehrere Typschlüssel werden und-verknüpft
;
; 4. Sonderausstattung S + 3-stellig numerisch Wildcard ? erlaubt Negation ! erlaubt
; Mehrere Sonderausstattungen werden und-verknüpft
;
; 5. Zusbau-Nummer Z + 7-stellig numerisch
;
;
;
;
;
;
;

[MUSTER]
????-??-??-??? 0F TAB?? T!AB44 S2?? S!201 S400 Z1234567

????-??-??-??? 02 T???? Z7654321
; Zusbau-Nummer 7654321 mit SG-Adresse 02 ist bei beliebiger Integrationsstufe ( immer )
; und beliebigem Typschlüssel ( immer ) verbaut
;

[E65]

[E60]

[RR1]

[E89X]

; EOF


Muster I_STUFE.DAT

Kopf der Konfigurationsdatei I_STUFE.DAT, der den Aufbau der Einträge erklärt.

; I_STUFE.DAT
;
; Soll-Integrationsstufe
;
; Datenformat einer Zeile:
;
; 1. Integrationsstufe EXXX-XX-XX-XXX
; alphanumerisch 14-stellig Wildcard ? erlaubt
;
; Integrationsstufe XX.XXXX ( altes Format )
; alphanumerisch 4 bis 7-stellig Wildcard ? erlaubt
;
; 2. Typschlüssel T + 4-stellig alphanumerisch Wildcard ? erlaubt Negation ! erlaubt
; Mehrere Typschlüssel werden und-verknüpft
;
; 3. Sonderausstattung S + 3-stellig numerisch Wildcard ? erlaubt Negation ! erlaubt
; Mehrere Sonderausstattungen werden und-verknüpft
;
; 4. Schlüsselwort Auto wenn Automatik-Mode.
; Soll-Integrationsstufe ist Ist-Integrationsstufe
;
; 5. IStufe
; Wenn angegeben wird IStufenlogik benutzt.
;
; 6. Istufe IXXXX-XX-XX-XXX
; alphanumerisch 14-stellig Wildcard ? nicht erlaubt
;
; Istufe IXX.XXXX ( altes Format )
; alphanumerisch 4 bis 7-stellig Wildcard ? nicht erlaubt
; Soll-Integrationsstufe
; Wird in Verbindung mit Auto nur benutzt, wenn Ist-Integrationsstufe ungültig ist
;

[MUSTER]
E060-03-04-400 TAB?? T!AB44 S2?? S!201 S400 IE060-03-04-500

????-??-??-??? T???? Auto IStufe IE060-03-04-510
; Bei beliebiger Integrationsstufe ( immer )
; und beliebigem Typschlüssel ( immer ) wird IStufenlogik mit Automatik-Mode
; benutzt. Ist die Ist-Integrationsstufe ungültig wird IStufe E060-03-04-510 benutzt

[E65]

[E60]

[RR1]

[E89X]

; EOF


Muster TRAILER.DAT

Beispiel für die Konfigurationsdatei TRAILER.DAT:

; TRAILER.DAT
;
; Baureihenbezogene Zuordnung von Steuergeräteadressen
;
; Datenformat einer Zeile:
;
; 1. Steuergerätebezeichnung
; alphanumerisch 3 bis 8-stellig
;
;
; 2. SG-Adresse 2-stellig hex
; mehrere Adressen werden mit ":" getrennt
;
;
[E65]
ACC = 21
AHM = 71
ALC = 22
AMP = 37
ARS = 23
ASK = 3F
AT = 47
BZM = 65
BZM_F = 66
CAS = 40
CDC = 3C
CID_F = 74
CIM = 42
DME_DDE = 12
DSC = 29
DWA = 41
ECO = 67
ECO_F = 68
EDCK = 39
EHC = 38
EMF = 2A
FBIE = 61
HKA = 79
HKL = 6B
IHKH = 78
KHI = 3A
KOMB = 60
LM = 70
MMC = 31
MMI = 62:63
MMIF = 32:34
NAVI = 3B
PA = 27
PDC = 64
PM = 43
RDC = 20
RLS = 45
SASL = 03
SASR = 04
SBSL = 09
SBSR = 0A
SDARS = 54
SEC1 = 49
SEC2 = 4A
SFZ = 0E
SHD = 44
SHZH = 7A
SGM = 00:01
SM_BF = 6E
SM_BFH = 6A
SM_FA = 6D
SM_FAH = 69
SSBF = 08
SSFA = 07
SSH = 0D
STVL = 05
STVR = 06
SVS = 35
SZL = 02
TEL = 36
TM_B = 4D
TM_BH = 4F
TM_F = 4C
TM_FH = 4E
VID = 4B
VVT = 1B:1E
WIM = 46
;
;
[E60]
ACC = 21
AFS = 16
AHM = 71
ALC = 22
AMP = 37
ARS = 23
CAS = 40
CCC = 47:3F:62:63:A0
MASK = 62:63:90:91
CDC = 3C
CID = 73
CID_F = 74
CVM = 24
DME_DDE = 12
DSC = 29
DWA = 41
DWA_SINE = 50
EGS_SMG = 18
EHC = 38
EKP = 17
HKL = 6B
HUD = 3D
IHKA = 78
KBM = 72
KHM = 3A
KOMB = 60
LM = 70
MMC65 = 31
MPM = 43
NAV = 3B
PDC = 64
PGS = 27
RDC = 20
RLS = 45
SBSL = A1
SBSR = A2
SDAR = 54
SFZ = 0E
SGM = 00:01
SHD = 44
SHZH = 7A
SMBF = 6E
SMFA = 6D
SZL = 02
SZM = 65
TEBF = 06
TEFA = 05
TEL = 36
VID = 4B
VVT1 = 1B:1E
ZBE = 67

[E89x]
JBBF = 00
MRSZ5 = 01
DME/DDE = 12
AFS90 = 16
EKP = 17
EGS/SMG = 18
VGSG90 = 19
LDM90 = 1C
FFP90 = 1D
ACC = 21
PGS2 = 27
DSC/DXC = 29
TCU = 36
AMP60 = 37
NAVI = 3B
CDC = 3C
CCC_ASK = 3F
CAS = 40
DWA_USIS = 41
MDS = 44
RLS = 45
VID = 4B
DWA_SINE = 50
SDAR = 54
FZD = 56
;IBOC_DAB = 5B
KOMBI = 60
PDC = 64
ZBE = 67
SM_FA = 6D
SM_BF = 6E
AHM = 71
FRM = 72
CID = 73
IHK = 78
CCC = 47:3F:62:63:A0
MASK = 3B:62:63:90:91:92

[RR1]
ACC = 21
AHM = 71
ALC = 22
AMP = 37
ARS = 23
ASK = 3F
AT = 47
BZM = 65
BZM_F = 66
CAS = 40
CDC = 3C
CID_F = 74
CIM = 42
DME_DDE = 12
DSC = 29
DWA = 41
ECO = 67
ECO_F = 68
EDCK = 39
EHC = 38
EMF = 2A
FBIE = 61
HKA = 79
HKL = 6B
IHKH = 78
KHI = 3A
KOMB = 60
LM = 70
MMC = 31
MMI = 62:63
MMIF = 32:34
NAVI = 3B
PA = 27
PDC = 64
PM = 43
RDC = 20
RLS = 45
SASL = 03
SASR = 04
SBSL = 09
SBSR = 0A
SDARS = 54
SEC1 = 49
SEC2 = 4A
SFZ = 0E
SHD = 44
SHZH = 7A
SGM = 00:01
SM_BF = 6E
SM_BFH = 6A
SM_FA = 6D
SM_FAH = 69
SSBF = 08
SSFA = 07
SSH = 0D
STVL = 05
STVR = 06
SVS = 35
SZL = 02
TEL = 36
TM_B = 4D
TM_BH = 4F
TM_F = 4C
TM_FH = 4E
VID = 4B
VVT = 1B:1E
WIM = 46
;
; EOF


Menü: Datei

Zurück zu:

Bedienung Hauptfenster

Menüs

Für Details Klick auf den Menüpunkt!


Menü: Datei | Starte neue Instanz

Zurück zu:

Bedienung Hauptfenster

Menü: Datei

Startet eine weitere Instanz von NFS. Es ist der gleichzeitige Betrieb von max. 9 Instanzen auf einem Rechner vorgesehen (Der Menüpunkt ist nur im Multiinstanzbetrieb sichtbar).


Menü: Datei | Beenden

Zurück zu:

Bedienung Hauptfenster

Menü: Datei

Beendet die Anwendung NFS (bzw. im Multiinstanzbetrieb diese Instanz von NFS)


Menü: Datei | Beende alle Instanzen

Zurück zu:

Bedienung Hauptfenster

Menü: Datei

Beendet alle auf diesem Rechner laufenden Instanzen von NFS (Der Menüpunkt ist nur im Multiinstanzbetrieb sichtbar).


Menü: Extras

Zurück zu:

Bedienung Hauptfenster

Menüs

Für Details Klick auf den Menüpunkt!


Menü: Extras | Kopfzeile anzeigen

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

Aus- bzw. Einblenden der Kopfzeile (Logo, Titel und Version/Verantwortlich/Anlage)

Durch das Ausblenden der Kopfzeile vergrößert sich der Anzeigebereich der Ergebnisanzeige.

Die gewählte Einstellung wird in der NFS.INI gespeichert und bleibt beim nächsten Programmstart erhalten.


Menü: Extras | Batterie und Zündung anzeigen

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

Aus- bzw. Einblenden der Anzeigen für Batterie und Zündung (Klemmenstatus)

Durch das Ausblenden des Klemmenstatus vergrößert sich der Anzeigebereich der Ergebnisanzeige.

Die gewählte Einstellung wird in der NFS.INI gespeichert und bleibt beim nächsten Programmstart erhalten.


Menü: Extras | Anzeige NFS.INI

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

Zeigt die Konfigurationsdatei von NFS an.


Menü: Extras | Anzeige ID_CHECK.DAT

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

Enthält SG mit unzuverlässig funktionierender Diagnose, die jedoch ausstattungsabhängig vorhanden sein müssen (wie zum Beispiel SINE)

Siehe auch:

Muster ID_CHECK.DAT


Menü: Extras | Anzeige AKTION.DAT

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

Liste von Steuergeräten, die (unabhängig vom Ergebnis des KMM) in den Umbauplan mit aufgenommen werden.

Siehe auch:

Muster AKTION.DAT


Menü: Extras | Anzeige NOFLASH.DAT

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

Liste der zu tauschenden Steuergeräte. Die in der Liste enthaltenen Steuergeräte dürfen nicht geflasht sondern müssen getauscht werden.

Siehe auch:

Muster NOFLASH.DAT


Menü: Extras | Anzeige SEQUENZ.DAT

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

Liste der Flashbedingungen und Programmierreihenfolgen. Hier wird festgelegt, bei welcher Stellung des Zündschlüssels und in welcher Reihenfolge die SG geflasht werden.

Siehe auch:

Muster SEQUENZ.DAT


Menü: Extras | Anzeige SGSIM.DAT

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

Liste der zu simulierenden Steuergeräte;

Enthält Steuergeräte, die im Fahrzeug aktuell nicht zur Verfügung stehen (z.B. Türe demontiert).

Siehe auch:

Muster SGSIM.DAT


Menü: Extras | Anzeige KMM_BACK.DAT

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

Enthält eine Liste von Inkompatibilitäten zwischen Steuergeräten, Typschlüsseln, I-Stufen etc.

Wird nur im KMM-Backup-Modus anstelle des KMM verwendet, siehe NFS.INI.

Siehe auch:

Muster KMM_BACK.DAT


Menü: Extras | Anzeige NOTFALL.DAT

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

Liste der für Notfallflashen erlaubten ZB-Nummern.

Siehe auch:

Konfiguration Notfallflashen

Muster NOTFALL.DAT


Menü: Extras | Anzeige ZB_CHECK.DAT

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

Liste der zu prüfenden ZB-Nummern der Steuergeräte

Siehe auch:

Muster ZB_CHECK.DAT


Menü: Extras | Anzeige I_STUFE.DAT

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

Enthält die Soll-Integrationsstufe

Siehe auch:

Muster I_STUFE.DAT


Menü: Extras | Anzeige Flashlogbuch

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

Programmiertagebuch; der Dateiname setzt sich aus Anlagenbezeichnung (in diesem Beispiel NFS_01) und der Kalenderwoche (24) zusammen

Enthält jeden einzelnen durchgeführten Flash-Vorgang mit Ergebnis (iO oder niO); jede Woche wird eine neue Datei begonnen


Menü: Extras | Anzeige FZG.TMP

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

Sämtliche Informationen zum letzten bearbeiteten Fahrzeug, wird beim nächsten Fahrzeug überschrieben


Menü: Extras | Anzeige ZB.TMP

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

Liste der aller Zusammenbaunummern, die über WinKFP programmiert werden können (Aussage über Fähigkeiten der verwendeten WinKFP-Version)


Menü: Extras | Anzeige FA.TRC

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

Liste aller geprüften Fahrzeuge mit Angaben zur Ausstattung (Fahrgestellnummer, Typschlüssel, SAs)


Menü: Extras | Anzeige ID.TRC

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

Liste aller geprüften Fahrzeuge mit den Identdaten der einzelnen Steuergeräte


Menü: Extras | Anzeige KMM.TRC

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

Liste aller vom KMM gelieferten Umbaupläne zu den Fahrzeugen; je Fahrzeug werden max. 10 Umbaupläne abgefragt, es wird aber immer nur der erste Umbauplan ausgeführt, weitere Umbaupläne dienen lediglich der Diagnose


Menü: Extras | Anzeige KMM_BACK.TRC

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

Beinhaltet die Ergebnisse der KMM Backup-Lösung (alternativ zu KMM bei aktivierter Option KMM_BACK=JA)


Menü: Extras | Anzeige CASCADE.XML

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

XML-Datei, die als Ergebnis eines CASCADE-Aufrufes generiert wurde (nur im CASCADE Betrieb); Enthält im IO-Fall den Umbauplan, im NIO-Fall lediglich eine Beschreibung des Fehlers


Menü: Extras | Anzeige FLASH.PRT

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

Ergebnis (Rückmeldung) von WinKFP nach Beendigung eines Auftrages (z.B. Flash-Auftrag). Im Mehrkanalbetrieb wird ein Untermenü mit einer Datei je Kanal angeboten.


Menü: Extras | Anzeige ERROR.TRC

Zurück zu:

Bedienung Hauptfenster

Menü: Extras

Liste aller Fehler, Warnungen und Bedieneingriffe;

Warnungen können über den Eintrag WARN_Log im Abschnitt [TRACE] in der NFS.INI abgeschaltet werden.


Menü: Notfallflashen

Zurück zu:

Bedienung Hauptfenster

Menüs

Startet den Ablauf Notfallflashen


Menü: Konfiguration

Zurück zu:

Bedienung Hauptfenster

Menüs

Das Menü ist nur sichtbar, wenn der Trailermode aktiviert ist.

Für Details Klick auf den Menüpunkt!


Menü: Konfiguration | Trailer Konfiguration

Zurück zu:

Bedienung Hauptfenster

Menü: Konfiguration

Öffnet den Dialog zur Konfiguration für den Trailerbetrieb.

Über diesen Dialog werden die Dateien KMM_BACK.DAT und ID_CHECK.DAT neu generiert.

Siehe auch:

Bedienung Konfiguration

Bedienung Konfiguration (Konflikt)


Menü: Konfiguration | Anzeige TRAILER.DAT

Zurück zu:

Bedienung Hauptfenster

Menü: Konfiguration

Baureihenbezogene Liste von Steuergeräten mit den zugeordneten Steuergeräteadressen.

Siehe auch:

Muster TRAILER.DAT


Menü: Konfiguration | <Trailerprofil>

Zurück zu:

Bedienung Hauptfenster

Menü: Konfiguration

Aktiviert das ausgewählte Trailerprofil. Die NFS.INI wird überschrieben und es wird automatisch eine Rekonfiguration durchgeführt.

Menüeinträge werden in der NFS.INI im Abschnitt [Trailerprofil] definiert.


Menü: TestMode

Zurück zu:

Bedienung Hauptfenster

Menüs

Für Details Klick auf den Menüpunkt!


Menü: TestMode | Erzeuge Rekonfigurationsdatei

Zurück zu:

Bedienung Hauptfenster

Menü: TestMode

Es werden alle Konfigurationsdateien neu eingelesen;

Wird benötigt, wenn bei laufendem Programm Konfigurationsdateien (*.INI, *.DAT) geändert werden; erst nach erfolgter Rekonfiguration arbeitet das Programm mit den aktualisierten Daten


Menü: TestMode | Interpretiere ID_CHECK.DAT

Zurück zu:

Bedienung Hauptfenster

Menü: TestMode

Prüft die Datei ID_CHECK.DAT (Anzeige von FZG.TMP).

Siehe auch:

Muster ID_CHECK.DAT


Menü: TestMode | Interpretiere AKTION.DAT

Zurück zu:

Bedienung Hauptfenster

Menü: TestMode

Prüft die Datei AKTION.DAT (Anzeige von FZG.TMP).

Siehe auch:

Muster AKTION.DAT


Menü: TestMode | Interpretiere NOFLASH.DAT

Zurück zu:

Bedienung Hauptfenster

Menü: TestMode

Prüft die Datei NOFLASH.DAT (Anzeige von FZG.TMP).

Siehe auch:

Muster NOFLASH.DAT


Menü: TestMode | Interpretiere KMM

Zurück zu:

Bedienung Hauptfenster

Menü: TestMode

Prüft die Gesamtkonfiguration und den Ablauf (Anzeige von FZG.TMP).


Menü: TestMode | Starte CASCADE ZB-Nr Check

Zurück zu:

Bedienung Hauptfenster

Menü: TestMode

Startet zu Testzwecken einen CASCADE-Ablauf mit dem Parameter ZB_CHECK (ohne Fahrgestellnummer)


Menü: TestMode | Starte CASCADE APP ZB-Nr Check

Zurück zu:

Bedienung Hauptfenster

Menü: TestMode

Startet zu Testzwecken einen CASCADE-Ablauf mit dem Parameter APP_ZB_CHECK (ohne Fahrgestellnummer)


Menü: TestMode | Starte CASCADE Automatic Flash

Zurück zu:

Bedienung Hauptfenster

Menü: TestMode

Startet zu Testzwecken einen CASCADE-Ablauf mit dem Parameter AUTOMATIC_FLASH (ohne Fahrgestellnummer)


Menü: TestMode | Lösche alle TraceDateien

Zurück zu:

Bedienung Hauptfenster

Menü: TestMode

Löscht die Protokolldateien im Verzeichnis TRACE mit Ausnahme des Programmiertagebuches.


Menü: Hilfe

Zurück zu:

Bedienung Hauptfenster

Menüs

Für Details Klick auf den Menüpunkt!


Menü: Hilfe | Hilfe

Zurück zu:

Bedienung Hauptfenster

Menü: Hilfe

Öffnet die NFS Online-Hilfe NFS.HLP (diese Datei).

Wenn die Englische Sprache voreingestellt ist, wird die Datei NFS_E.HLP verwendet.


Menü: Hilfe | Info

Zurück zu:

Bedienung Hauptfenster

Menü: Hilfe

Öffnet das Info-Fenster mit Versionsinfo, Copyright-Vermerken und einer Historie über durchgeführte Änderungen (Erweiterungen bzw. Fehlerbehebungen)


Menü: Datei (Anzeigefenster)

Zurück zu:

Bedienung Hauptfenster

Für Details Klick auf den Menüpunkt!


Menü: Datei | Edit (Anzeigefenster)

Schaltet die aktuell angezeigte Datei in den Edit-Modus. Der Dateiinhalt kann jetzt geändert werden.

Achtung: wenn Sie Änderungen an den angezeigten Dateien vornehmen, kann dies Ablaufstörungen bis hin zur vollständigen Betriebsunfähigkeit von NFS verursachen.


Menü: Datei | Speichern (Anzeigefenster)

Nur anwählbar, wenn der Edit-Modus aktiviert ist,

überschreibt die ausgewählte Datei mit dem aktuellen (geänderten) Inhalt des Anzeigebereiches


Menü: Datei | Drucken (Anzeigefenster)

Druckt den Inhalt des Anzeigebereiches


Menü: Datei | Beenden (Anzeigefenster)

Schließt das Anzeigefenster

Wenn sich ungesicherte Änderungen im Anzeigefenster befinden wird nachgefragt, ob diese gespeichert werden sollen


Start Taste

Zurück zu:

Bedienung Hauptfenster

Die Taste kann im Normalablauf erst dann bedient werden, wenn ein Fahrzeug angeschlossen und die Zündung eingeschaltet ist.


Weiter Taste

Zurück zu:

Bedienung Hauptfenster

Nur sichtbar und bedienbar, wenn im Ablauf eine Eingabe des Bedieners erwartet wird.


Abbruch Taste

Zurück zu:

Bedienung Hauptfenster

Nur sichtbar und bedienbar, wenn im Ablauf eine Eingabe des Bedieners erwartet wird.


Ignorieren Taste

Zurück zu:

Bedienung Hauptfenster

Nur sichtbar und bedienbar, wenn im Ablauf eine Eingabe des Bedieners erwartet wird.

Bei Betätigung der Taste werden abweichend vom Normalablauf bestimmte Aktionen (Warteschritte, Prüfungen) unterbrochen oder übersprungen. Die Betätigung wird zur Nachvollziehbarkeit in der Trace-Datei (ERROR.TRC) aufgezeichnet.


Drucken Taste

Zurück zu:

Bedienung Hauptfenster

Druckt den momentanen Inhalt des Textfeldes Anweisung am Standard-Drucker des Rechners aus und dient in erster Linie zur Dokumentation von NIO Ergebnissen sowie des Ausdrucks der Liste mit den zu tauschenden Steuergeräten.

Der Taster ist nur in folgenden Ablaufzuständen sichtbar:

·Anzeige der zu tauschenden und zu flashenden Steuergeräte

·Prüfung des Fahrzeuges NIO

·Notfall-Flashen NIO

Anmerkung: ist am Rechner kein Drucker konfiguriert, wird der Taster zwar sichtbar, bleibt jedoch disabled.


NFS.INI [ANZEIGE] WinPos…

Fensterpositionen für nächsten Programmstart; Informationen werden vom Programm automatisch generiert.


NFS.INI [Konfiguration] MULTIINSTANZ

Format:String

Default:"N"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob NFS im Multiinstanzmodus betrieben wird (JA/NEIN).


NFS.INI [BAUREIHENMATRIX] Auftrag_SGBD

Format:String

Nur für Motorrad Berlin verwenden!

Dieser Eintrag bezeichnet eine SGBD, die anstelle der SGBD "CAS" für den Bezug des Fahrzeugauftrages verwendet wird (identische Jobs und Results werden vorausgesetzt).

Beispiel:

[BAUREIHENMATRIX]

Auftrag_SGBD = MRK24


NFS.INI [ANZEIGE] Kopfzeile

Format:String

Default:"J"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob eine Kopfzeile angezeigt wird (JA/NEIN). Diese Einstellung kann über das Menü "Extras" geändert werden.


ANLAGE.INI [KONFIGURATION] Anlage

Format:String

Default:"N"

Enthält die Bezeichnung des Prüfplatzes und erscheint im Hauptfenster. Das Logbuch wird unter diesem Namen geführt (z.B. NFS_01).


NFS.INI [Exx] UBatt_RESULT

Format:String

Der hier eingestellte Parameter wird ohne Prüfung 1:1 als Result-Namen an das EDIABAS-Interface übergeben und muss als Rückgabewert des entsprechenden SGBD-Jobs definiert sein (Bordnetzspannung).

Siehe auch:

[Exx]


NFS.INI [Exx] UBatt_SGBD

Format:String

Der hier eingestellte Parameter wird ohne Prüfung 1:1 als ECU an das EDIABAS-Interface übergeben und bezeichnet die SGBD, die für die entsprechende Fahrzeugreihe definiert sein muss.

Siehe auch:

[Exx]


NFS.INI [ANZEIGE] BatterieZuendung

Format:String

Default:"J"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob der Klemmenstatus angezeigt wird (JA/NEIN). Diese Einstellung kann über das Menü "Extras" geändert werden.


NFS.INI [Exx] UBatt_JOB

Format:String

Der hier eingestellte Parameter wird ohne Prüfung 1:1 als JOB an das EDIABAS-Interface übergeben und muss in der entsprechenden SGBD der Fahrzeugreihe definiert sein.

Siehe auch:

[Exx]


NFS.INI [Trace] WARN_Log

Format:String

Default:"N"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob neben den Fehlermeldungen auch Warnungen einer Datei aufgezeichnet werden (JA/NEIN).

Datei = \..\TRACE\ERROR.TRC

Inhalt: Fehlermeldungen und ggf. Warnhinweise


NFS.INI [Exx] UBatt_MIN

Format:Integer

Unterer Grenzwert zur Überprüfung des Ergebnisses "Bordnetzspannung"

Siehe auch:

[Exx]


NFS.INI [Exx] UBatt_MAX

Format:Integer

Oberer Grenzwert zur Überprüfung des Ergebnisses "Bordnetzspannung"

Siehe auch:

[Exx]


NFS.INI [Konfiguration] FIXEDWINDOW

Format:String

Default:"N"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob die Fenster automatisch angeordnet werden (JA/NEIN). Bei "J" können die Fenster der Instanzen nicht vom Anwender positioniert werden, sondern werden automatisch vom Programm angeordnet.


NFS.INI [Konfiguration] HO_MODUS

Format:String

Default:"N"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob NFS im HO-Modus betrieben wird (JA/NEIN).


NFS.INI [Trailerprofil]

Format:String

In diesem Abschnitt werden die Trailerprofile für das Menü Konfiguration definiert. Maximal können 9 Profile definiert werden. Die Nummerierung muss nicht fortlaufend erfolgen, so dass vorübergehend nicht benötigte Profile auskommentiert werden können.

Mögliche Einträge sind: Text_1, Text_2 usw. bis Text_9 bzw. Datei_1, Datei_2 usw. bis Datei_9.


NFS.INI [Konfiguration] SIGNALLEUCHTE

Format:String

Default:"N"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob Signalleuchten angesteuert werden oder nicht (JA/NEIN). Wird nur in Verbindung mit dem Trailerbetrieb benötigt.


NFS.INI [Trace] ID_Log

Format:String

Default:"N"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob die Fahrzeug-Identdaten in einer Datei aufgezeichnet werden (JA/NEIN).

Datei = \..\TRACE\ID.TRC

Inhalt: die aus dem Fahrzeug ausgelesenen Identdaten


NFS.INI [Konfiguration] Retry

Format:Integer

Default:2

Anmerkung:kann auf 0 gesetzt werden

Angabe der Wiederholungsversuche beim Zugriff auf das Fahrzeug über EDIABAS; kann auf 0 gesetzt werden, da EDIABAS bereits intern Wiederholungen durchführt; der hier angegebene Wert ist als Multiplikator der internen Wiederholversuche von EDIABAS zu verstehen


NFS.INI [Konfiguration] FLASH_ZBNR_ALLWAYS

Format:String

Default:"N"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob die in der AKTION.DAT enthaltenen Flash-Anweisungen unabhängig der Ergebnisse von KMM/KMM_BACK auf jeden Fall ausgeführt werden sollen (JA/NEIN).


NFS.INI [Konfiguration] TestModus

Format:String

Default:"N"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob das Menü "TestModus" angezeigt wird (JA/NEIN).


NFS.INI [Trace] KMM_Log

Format:String

Default:"N"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob in einer Datei aufgezeichnet wird (JA/NEIN).

Datei = \..\TRACE\KMM.TRC

Inhalt: Umbaupläne des Kompatibilitätsmanagements


NFS.INI [REKONFIGURATION] DateiNameAus

Format:String

Default:"C:\NFS\BATCH\MESSAGE.OLD"

Nach Durchführung einer Rekonfiguration aufgrund der o.g. Datei wird DateiNameEin in DateiNameAus umbenannt (Namenskonvention im Multiinstanzbetrieb siehe unter DateiNameEin).


NFS.INI [Konfiguration] ON_KMM_PROBLEM_TRY_TO_FLASH

Format:String

Default:"N"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob ein Flash ausgeführt wird, wenn das KMM keine eindeutige Entscheidung liefert (JA/NEIN).


NFS.INI [Trace] ZB_Log

Format:String

Mögliche Einträge sind: Text_1, Text_2 usw. bis Text_9

Legt den Text für den Menüeintrag im Menü Konfiguration fest.


NFS.INI [Exx]

Format:String

Dieser Abschnitt kann optional für einzelne Baureihen vorhanden sein und ist dann erforderlich, wenn SGBD-Name, Job oder Result bei der Ermittlung von den Standardvorgaben abweichen.

Standardmäßig werden folgende Vorgaben verwendet:

Parameter | Wert
UBatt_SGBD | "UTILITY"
UBatt_JOB | "STATUS_ZUENDUNG"
UBatt_RESULT | "STAT_ZUENDUNG"
UBatt_MIN | 1
UBatt_MAX | 1

Anmerkung: Standardmäßig wird ein boolsches Ergebnis (0 oder 1) geliefert. Deshalb sind beide Grenzwerte auf 1 gesetzt. Wenn hingegen ein Spannungswert geliefert wird, sind auch die Grenzwerte entsprechend anzupassen.


NFS.INI [Konfiguration] KMM_BACK

Format:String

Default:"N"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob die Backup-Lösung für die das KMM verwendet werden soll; anstelle des KMM kommt dann der Inhalt der Datei KMM_BACK.DAT zur Anwendung (JA/NEIN).

Wird verwendet, wenn bei Neuerungen das KMM noch nicht am neuesten Stand ist, oder das Ergebnis des KMM bewusst umgangen werden soll (z.B. im Trailerbetrieb)


NFS.INI [Konfiguration] STICHPROBE

Format:String

Default:"N"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob NFS im Stichprobenmodus betrieben wird (JA/NEIN).


NFS.INI [Konfiguration] TRAILERMODUS

Format:String

Default:"N"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob NFS im Trailermodus betrieben wird (JA/NEIN).


NFS.INI [Trace] FA_Log

Format:String

Default:"N"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob in einer Datei aufgezeichnet wird (JA/NEIN).

Datei = \..\TRACE\FA.TRC

Inhalt: Auftragsdaten des Fahrzeugs


NFS.INI [Konfiguration] Logo

Format:String

Default:"D"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Es wird festgelegt, welches Logo angezeigt wird:

·"" = BMW Group Logo(Default, BMW&Mini)

·B = BMW Logo (es werden 2 Logos je nach Spracheinstellung (siehe Language) unterschieden)

·R = Rolls Royce Logo

·M = Mini Logo

Dient der Individualisierung der Bedienoberfläche abhängig vom Einsatzort.


Menü: TestMode | Starte CASCADE APP Automatic Flash

Zurück zu:

Bedienung Hauptfenster

Menü: TestMode

Startet zu Testzwecken einen CASCADE-Ablauf mit dem Parameter APP_AUTOMATIC_FLASH (ohne Fahrgestellnummer)


NFS.INI [Trailerprofil] Datei_x

Format:String (Pfad+Dateiname)

Mögliche Einträge sind: Datei_1, Datei_2 usw. bis Datei_9

Legt die Quelldatei fest, mit der NFS.INI bei der Auswahl des zugehörigen Menüpunktes im Menü Konfiguration überschrieben wird.


NFS.INI [BAUREIHENMATRIX] Exx

Format:String

Die Baureihenmatrix ist eine Art Übersetzungsliste für Baureihen. Zu jeder Baureihenbezeichnung kann festgelegt werden, welche Parameter und Behandlung einer anderen Baureihe im weiteren Programmablauf verwendet werden sollen.

Beispiel (E66 und E67 werden in Folge wie E65 behandelt)

[BAUREIHENMATRIX]

E66 = E65

E67 = E65


NFS.INI [Konfiguration] ZB_CHECK

Format:String

Default:"N"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob eine ZB-Nummern-Prüfung durchgeführt wird (JA/NEIN). Dabei wird nur das AIF überprüft und es werden keine Flash-Aufträge durchgeführt.


NFS.INI [REKONFIGURATION] DateiNameEin

Format:String

Default:"C:\NFS\BATCH\MESSAGE.MSG"

Wird dazu verwendet, um NFS davon zu benachrichtigen, dass sich die Konfiguration geändert hat. Wenn sich NFS im Leerlauf befindet und diese Datei erkennt, wird automatisch eine Rekonfiguration durchgeführt und die aktuellen Parameterdateien neu eingelesen.

Hinweis: Im Multiinstanzbetrieb wird an den Dateinamen die Instanznummer angefügt. So prüft NFS im Mutiinstanzbetrieb die erste Instanz auf die Datei MESSAGE_1.MSG, die 2. Instanz auf MESSAGE_2.MSG usw.


NFS.INI [Trace] ZB_Log

Format:String

Default:"N"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob die ZB-Nummern in einer Datei aufgezeichnet werden (JA/NEIN).

Datei = \..\TRACE\ZB.TMP

Inhalt: Datei mit Zusammenbaunummern (Winkfp)


NFS.INI [Trace] FZG_Log

Format:String

Default:"N"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob die Fahrzeuginformation in einer Datei aufgezeichnet wird (JA/NEIN/SICHERN).

Datei = \..\TRACE\FZG.TMP

Inhalt: Alle zu diesem Fahrzeug bekannten Informationen (werden beim nächsten Fahrzeug wieder überschrieben)

Bei der Option SICHERN wird zusätzlich für jedes Fahrzeug eine Sicherungskopie angelegt. Der Dateiname der Sicherungskopie ist <Fahrgestellnummer>.TRC


NFS.INI [Konfiguration] ON_ZBNR_ERROR_USE_IDNR

Format:String

Default:"N"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob bei nicht ermittelbarer ZB-Nummer mit der HW*-Nummer weitergearbeitet werden soll (JA/NEIN).)


NFS.INI [Konfiguration] Language

Format:String

Default:"D"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Es wird festgelegt, welche Sprache verwendet wird

D = Deutsch
E = Englisch


NFS.INI [Konfiguration] AuftragSimulieren

Format:String

Default:"N"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob der Fahrzeugauftrag simuliert wird (JA/NEIN).


NFS.INI [Konfiguration] ON_IDNR_ERROR_USE_ZBNR

Format:String

Default:"N"

Anmerkung:Es ist nur der 1. Buchstabe relevant.

Legt fest, ob bei nicht ermittelbarer HW*-Nummer mit der ZB-Nummer weitergearbeitet werden soll (JA/NEIN)